aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pylint
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-30 19:04:30 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-30 21:05:50 +0100
commit63f5e7d295659a855709901ce22a3e5f40fce455 (patch)
treeebd2abfa5f6629423b3b5902ce88ffdeb329b0f0 /testing/pylint
parent5bca7d4880028b18028b0b5dbcd20c32f145d67e (diff)
downloadaports-63f5e7d295659a855709901ce22a3e5f40fce455.tar.bz2
aports-63f5e7d295659a855709901ce22a3e5f40fce455.tar.xz
[various]: unify names of licenses according to SPDX
This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
Diffstat (limited to 'testing/pylint')
-rw-r--r--testing/pylint/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
index 541bb2011d..89a2ab0d9a 100644
--- a/testing/pylint/APKBUILD
+++ b/testing/pylint/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="http://pypi.python.org/pypi/pylint"
arch="noarch"
-license="GPL2+"
+license="GPL-2.0-or-later"
depends="py-mccabe py-six py-isort py-astroid"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"