aboutsummaryrefslogtreecommitdiffstats
path: root/testing/python3.4
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-09-22 10:15:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-09-22 10:15:25 +0000
commitc58776022367c8881218efed8ee032a91cd17e06 (patch)
treef2a40542c4dbfc2ee60c5c1af0a15485b93ca476 /testing/python3.4
parent73010e7106df9a632d3bc2609e8f50376cfc3072 (diff)
downloadaports-c58776022367c8881218efed8ee032a91cd17e06.tar.bz2
aports-c58776022367c8881218efed8ee032a91cd17e06.tar.xz
testing/python3.4: renamed form python34
and remove maintainer
Diffstat (limited to 'testing/python3.4')
-rw-r--r--testing/python3.4/APKBUILD89
1 files changed, 89 insertions, 0 deletions
diff --git a/testing/python3.4/APKBUILD b/testing/python3.4/APKBUILD
new file mode 100644
index 0000000000..ad4342d9e0
--- /dev/null
+++ b/testing/python3.4/APKBUILD
@@ -0,0 +1,89 @@
+# Contributor: Gus Monod <gustave.monod@insa-lyon.fr>
+
+pkgname=python3.4
+pkgver=3.4.3
+pkgrel=0
+pkgdesc="A high-level scripting language"
+url="http://www.python.org"
+arch="all"
+license="custom"
+depends=""
+makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
+ sqlite-dev libffi-dev tcl-dev linux-headers gdbm-dev readline-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz"
+
+builddir="$srcdir/Python-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ # force system libs
+ rm -r Modules/expat \
+ Modules/zlib \
+ Modules/_ctypes/darwin* \
+ Modules/_ctypes/libffi* \
+ || return 1
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-rpath \
+ --enable-ipv6 \
+ --enable-loadable-sqlite-extensions \
+ --enable-shared \
+ --with-computed-gotos \
+ --with-dbmliborder=gdbm:ndbm \
+ --with-system-expat \
+ --with-system-ffi \
+ --with-threads \
+ || return 1
+
+ make EXTRA_CFLAGS="$CFLAGS" || return 1
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" EXTRA_CFLAGS="$CFLAGS" install maninstall \
+ || return 1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ local _basever="${pkgver%.*}"
+ ln -sf ../../libpython${_basever}m.so \
+ "${pkgdir}/usr/lib/python${_basever}/config-${_basever}m/libpython${_basever}m.so"
+}
+
+_mv_files() {
+ cd "$pkgdir"/usr/lib/python${pkgver%.*}
+ for i in */test */tests; do
+ mkdir -p "$subpkgdir"/usr/lib/python${pkgver%.*}/"$i"
+ mv "$i"/* "$subpkgdir"/usr/lib/python${pkgver%.*}/"$i"
+ rm -rf "$i"
+ done
+ mv "$pkgdir"/usr/lib/python${pkgver%.*}/test \
+ "$subpkgdir"/usr/lib/python${pkgver%.*}
+}
+
+dev() {
+ # pyconfig.h is needed runtime so we move it back
+ default_dev
+ mkdir -p "$pkgdir"/usr/include/python${pkgver%.*}m
+ mv "$subpkgdir"/usr/include/python${pkgver%.*}m/pyconfig.h \
+ "$pkgdir"/usr/include/python${pkgver%.*}m/
+}
+
+tests() {
+ pkgdesc="The test modules from the main python package"
+ arch="noarch"
+
+ cd "$pkgdir"
+ _mv_files
+}
+
+md5sums="7d092d1bba6e17f0d9bd21b49e441dd5 Python-3.4.3.tar.xz"
+sha256sums="b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8 Python-3.4.3.tar.xz"
+sha512sums="55b2d7c07da8ad3a3971b4687da2e45809c6f1474732e93b0432f121f287d0b63ad8a9bf381987ea70f47a03d9474c3e55b7d86d14800bf7ef29b3324d8d35b9 Python-3.4.3.tar.xz"