aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qmlrunner
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 21:26:21 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:34:02 -0300
commitb59700ece3070a831a9c160b78f874cabe6d460f (patch)
treeada48dd1a2d207bad30640eb4c66a2c2fbb5409c /testing/qmlrunner
parent114d62f87b51825011bb6afaacf6225ecca88c83 (diff)
downloadaports-b59700ece3070a831a9c160b78f874cabe6d460f.tar.bz2
aports-b59700ece3070a831a9c160b78f874cabe6d460f.tar.xz
testing/qmlrunner: new aport
Diffstat (limited to 'testing/qmlrunner')
-rw-r--r--testing/qmlrunner/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/qmlrunner/APKBUILD b/testing/qmlrunner/APKBUILD
new file mode 100644
index 0000000000..4519e12e03
--- /dev/null
+++ b/testing/qmlrunner/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qmlrunner
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Runner for QML-only apps"
+url="https://github.com/rinigus/qmlrunner"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rinigus/qmlrunner/archive/$pkgver.tar.gz"
+options="!check"
+
+build() {
+ qmake-qt5 \
+ PREFIX=/usr
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="1157eee4e26b64fdb968416198de5bd96f57a002d9a07df0c26bf6111ad35244e4c0ab214d739121bfd547fc1ea35cec26986507d4eda51fa6442998e5284ecb qmlrunner-1.0.1.tar.gz"