aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qownnotes
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 03:31:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 14:56:28 -0300
commit78e9dc8e464f7bec0e2135b0be07f346522586b3 (patch)
treefbaa848524783d98bcfe9cd3eaf2e940f8832f98 /testing/qownnotes
parent70acd16c277ef98ae06cf0b028fa762e37e8de17 (diff)
downloadaports-78e9dc8e464f7bec0e2135b0be07f346522586b3.tar.bz2
aports-78e9dc8e464f7bec0e2135b0be07f346522586b3.tar.xz
testing/qownnotes: fix a few things
- url= - license= - trailing whitespace - usage of space instead of tabs for indentation - usage of $pkgname in source
Diffstat (limited to 'testing/qownnotes')
-rw-r--r--testing/qownnotes/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/testing/qownnotes/APKBUILD b/testing/qownnotes/APKBUILD
index b91212fa30..4d6987bbf3 100644
--- a/testing/qownnotes/APKBUILD
+++ b/testing/qownnotes/APKBUILD
@@ -2,16 +2,15 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname="qownnotes"
pkgver="19.8.8"
-pkgrel=0
+pkgrel=1
pkgdesc="Plain-text file markdown note taking with Nextcloud/ownCloud integration"
-url="http://www.qownnotes.org/"
+url="https://www.qownnotes.org/"
arch="all !ppc64le !s390x"
-license="GPL-2.0"
-makedepends="qt5-qtdeclarative-dev qt5-qtsvg-dev qt5-qtxmlpatterns-dev
-qt5-qttools-dev qt5-qtbase-dev qt5-qtwebsockets-dev"
+license="GPL-2.0-only"
+makedepends="qt5-qtdeclarative-dev qt5-qtsvg-dev qt5-qtxmlpatterns-dev
+ qt5-qttools-dev qt5-qtbase-dev qt5-qtwebsockets-dev botan-dev"
subpackages="$pkgname-lang"
-source="https://download.tuxfamily.org/${pkgname}/src/${pkgname}-${pkgver}.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://download.tuxfamily.org/qownnotes/src/qownnotes-${pkgver}.tar.xz"
prepare() {
default_prepare
@@ -40,8 +39,8 @@ package() {
}
lang() {
- install -d "${subpkgdir}/usr/share/QOwnNotes/languages/"
- install -D -m644 ${builddir}/languages/*.qm "${subpkgdir}/usr/share/QOwnNotes/languages/"
+ install -d "${subpkgdir}/usr/share/QOwnNotes/languages/"
+ install -D -m644 ${builddir}/languages/*.qm "${subpkgdir}/usr/share/QOwnNotes/languages/"
}
sha512sums="52cba0e03cc3ce955a3d80a6de443ea8930f384b6e037250af44e2487de6e856b7ec8364c1dd93b9267ccbdcc98d4a61a9fced0d17bbecff32ba80bbaa504a34 qownnotes-19.8.8.tar.xz"