aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qownnotes
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-08-28 06:13:19 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-08-28 06:13:23 +0000
commitf1d61d1ef650c954084e34dbbe68737f988c54d0 (patch)
tree48ca5f18098c1fe70a5d8ac9e558584248c4dc83 /testing/qownnotes
parent94c0de9b70a570239966a99024f83779ef71a324 (diff)
downloadaports-f1d61d1ef650c954084e34dbbe68737f988c54d0.tar.bz2
aports-f1d61d1ef650c954084e34dbbe68737f988c54d0.tar.xz
testing/qownnotes: new aport
Diffstat (limited to 'testing/qownnotes')
-rw-r--r--testing/qownnotes/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/qownnotes/APKBUILD b/testing/qownnotes/APKBUILD
new file mode 100644
index 0000000000..fe118d6067
--- /dev/null
+++ b/testing/qownnotes/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="qownnotes"
+pkgver="19.8.8"
+pkgrel=0
+pkgdesc="Plain-text file markdown note taking with Nextcloud/ownCloud integration"
+url="http://www.qownnotes.org/"
+arch="all"
+license="GPL-2.0"
+makedepends="qt5-qtdeclarative-dev qt5-qtsvg-dev qt5-qtxmlpatterns-dev
+qt5-qttools-dev qt5-qtbase-dev qt5-qtwebsockets-dev"
+subpackages="$pkgname-lang"
+source="https://download.tuxfamily.org/${pkgname}/src/${pkgname}-${pkgver}.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ echo "#define RELEASE \"Alpine Linux\"" > release.h
+}
+
+build() {
+ /usr/lib/qt5/bin/qmake \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+ QMAKE_LFLAGS_RELEASE="${LDFLAGS}"
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ install -D -m755 QOwnNotes "${pkgdir}/usr/bin/QOwnNotes"
+ install -D -m644 PBE.QOwnNotes.desktop "${pkgdir}/usr/share/applications/PBE.QOwnNotes.desktop"
+ install -D -m644 "images/icons/128x128/apps/QOwnNotes.png" "${pkgdir}/usr/share/pixmaps/QOwnNotes.png"
+ for format in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512 ; do
+ install -D -m644 "images/icons/${format}/apps/QOwnNotes.png" "${pkgdir}/usr/share/icons/hicolor/$format/apps/QOwnNotes.png"
+ done
+}
+
+lang() {
+ install -d "${subpkgdir}/usr/share/QOwnNotes/languages/"
+ install -D -m644 ${builddir}/languages/*.qm "${subpkgdir}/usr/share/QOwnNotes/languages/"
+}
+
+sha512sums="52cba0e03cc3ce955a3d80a6de443ea8930f384b6e037250af44e2487de6e856b7ec8364c1dd93b9267ccbdcc98d4a61a9fced0d17bbecff32ba80bbaa504a34 qownnotes-19.8.8.tar.xz"