aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qt5-qtwebview/APKBUILD
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2020-02-21 09:32:59 +0700
committerLeo <thinkabit.ukim@gmail.com>2020-02-21 13:11:30 -0300
commit36e1ff18b4cab3b07307c1f87e37233549a19049 (patch)
treed0d91842e198057b82b1884514756a27496b450b /testing/qt5-qtwebview/APKBUILD
parent6e7374531e42d1bfea7bc1df3954abd0e415fe2a (diff)
downloadaports-36e1ff18b4cab3b07307c1f87e37233549a19049.tar.bz2
aports-36e1ff18b4cab3b07307c1f87e37233549a19049.tar.xz
testing/qt5-qtwebview: new aport
Signed-off-by: Danct12 <danct12@disroot.org>
Diffstat (limited to 'testing/qt5-qtwebview/APKBUILD')
-rw-r--r--testing/qt5-qtwebview/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/qt5-qtwebview/APKBUILD b/testing/qt5-qtwebview/APKBUILD
new file mode 100644
index 0000000000..2e69266bee
--- /dev/null
+++ b/testing/qt5-qtwebview/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname=qt5-qtwebview
+pkgver=5.12.5
+pkgrel=0
+pkgdesc="Provides a way to display web content in a QML application"
+url="https://www.qt.io/developers/"
+# ppc64le, s390x: not supported by qt5-qtwebengine
+arch="all !ppc64le !s390x !armhf" # armhf blocked by qt5-qtdeclarative
+license="LGPL-3.0-only AND GPL-2.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+depends="qt5-qtwebengine"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+subpackages="$pkgname-dev"
+options="!check" # no testsuite
+
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+
+source="http://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtwebview-everywhere-src-$pkgver.tar.xz"
+
+builddir="$srcdir/${pkgname/qt5-/}-everywhere-src-$pkgver"
+
+build() {
+ qmake-qt5 CONFIG+="lang-all handwriting"
+ make
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}
+
+sha512sums="310beedf88cefc05458e99838e7cb71971aa24ba6c460ff3da804c2ab7f56167ca1067ddca71ee29ced32ea974fe405261f24c8bbcac0c7b69063d7c4e38a4de qtwebview-everywhere-src-5.12.5.tar.xz"