aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qtchooser
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-04 19:34:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-19 16:34:56 -0300
commitad0294f4ae4ff0c97591c859e4355d8d2b9cfbf0 (patch)
treebb50bdda09131fc4542c890631dc6b85a84d7b7e /testing/qtchooser
parent9760dbc95307b7deb8b5df03df91ed5216fe382e (diff)
downloadaports-ad0294f4ae4ff0c97591c859e4355d8d2b9cfbf0.tar.bz2
aports-ad0294f4ae4ff0c97591c859e4355d8d2b9cfbf0.tar.xz
testing/qtchooser: new aport
Diffstat (limited to 'testing/qtchooser')
-rw-r--r--testing/qtchooser/APKBUILD32
-rw-r--r--testing/qtchooser/qt5.conf2
2 files changed, 34 insertions, 0 deletions
diff --git a/testing/qtchooser/APKBUILD b/testing/qtchooser/APKBUILD
new file mode 100644
index 0000000000..3e7f98aa1e
--- /dev/null
+++ b/testing/qtchooser/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qtchooser
+pkgver=66
+pkgrel=0
+pkgdesc="Wrap the other Qt tools by searching for different instances of Qt on the system"
+arch="all"
+url="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
+license="GPL-3.0-only OR LGPL-2.1-only"
+source="https://download.qt.io/official_releases/qtchooser/$pkgname-$pkgver.tar.xz
+ qt5.conf
+ "
+subpackages="$pkgname-doc"
+
+build() {
+ bindir=/usr/lib/qtchooser/ make
+}
+
+package() {
+ install_if="qtbase"
+ INSTALL_ROOT="$pkgdir" make install
+
+ install -d "$pkgdir"/etc/xdg/qtchooser
+ install -m644 "$srcdir"/qt5.conf \
+ "$pkgdir"/etc/xdg/qtchooser/
+
+ # Set the default Qt
+ ln -s /etc/xdg/qtchooser/qt5.conf \
+ "$pkgdir"/etc/xdg/qtchooser/default.conf
+}
+sha512sums="0c7d3588ddd7b21e6e9d799204924e06e0b0950c898dfd23088f1e7657b7f821a35579aa062658499809f9d9757e82c3c592591aa2e5ec453463929bf2b33bac qtchooser-66.tar.xz
+aa1c18df9d5279ff00d06a0b3f19223e36e64f6275cf3ebc5a4be1e41bb139787325b88f89e0133e9960a7b2582716962dd5d195202ff68715883ce41babda73 qt5.conf"
diff --git a/testing/qtchooser/qt5.conf b/testing/qtchooser/qt5.conf
new file mode 100644
index 0000000000..edaadebd82
--- /dev/null
+++ b/testing/qtchooser/qt5.conf
@@ -0,0 +1,2 @@
+/usr/lib/qt5/bin
+/usr/lib