aboutsummaryrefslogtreecommitdiffstats
path: root/testing/radare2
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2018-02-10 03:15:35 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-13 14:28:40 +0000
commit934d43aaca5b4dbd2ed14c5a94485a6639ddbd18 (patch)
treea2c002a25addf081daa940d3a3e92522d77aab3e /testing/radare2
parent41d9695b25c6f1ef697329a1500410b720e2a46b (diff)
downloadaports-934d43aaca5b4dbd2ed14c5a94485a6639ddbd18.tar.bz2
aports-934d43aaca5b4dbd2ed14c5a94485a6639ddbd18.tar.xz
testing/[various]: fixes on s390x
need py-numpy : py-cpuinfo, websockify, py-gnuplot, py-scipy, py-fonttools, py-matplotlib, py-opengl need openblas : harminv no jit support : texlive no arch support : tcc, nim, perl-sys-syscall radare2 : need disabling debugger thermald : seems to be intel-only thing lazperf : io tests hang
Diffstat (limited to 'testing/radare2')
-rw-r--r--testing/radare2/APKBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/testing/radare2/APKBUILD b/testing/radare2/APKBUILD
index 4e869da8d1..d3c94f7200 100644
--- a/testing/radare2/APKBUILD
+++ b/testing/radare2/APKBUILD
@@ -20,6 +20,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pk
builddir="$srcdir"/$pkgname-$pkgver
build() {
+ [ "$CARCH" = "s390x" ] && _disable_debugger="--disable-debugger"
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -28,6 +29,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ $_disable_debugger \
--with-syscapstone \
--with-openssl \
--with-syszip