aboutsummaryrefslogtreecommitdiffstats
path: root/testing/randrctl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-22 16:10:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-22 16:34:54 -0300
commit9dc630355c0b9183cad6a87ba59f153ee63baf9d (patch)
treed17fd5da14649e8ad7b4a8454d49e811449f416f /testing/randrctl
parent4298d8a1fb7c0a1d2b0fe4b6dcc683771d163d77 (diff)
downloadaports-9dc630355c0b9183cad6a87ba59f153ee63baf9d.tar.bz2
aports-9dc630355c0b9183cad6a87ba59f153ee63baf9d.tar.xz
testing/randrctl: upgrade to 1.8.2
Diffstat (limited to 'testing/randrctl')
-rw-r--r--testing/randrctl/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/testing/randrctl/APKBUILD b/testing/randrctl/APKBUILD
index fdb95d3daf..60ab2992ad 100644
--- a/testing/randrctl/APKBUILD
+++ b/testing/randrctl/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=randrctl
-pkgver=1.8.0
-pkgrel=2
+pkgver=1.8.2
+pkgrel=0
pkgdesc="Profile based screen manager for X"
url="https://github.com/edio/randrctl"
arch="noarch"
@@ -10,28 +10,23 @@ license="GPL-3.0-or-later"
depends="python3 py3-argcomplete py3-yaml xrandr"
checkdepends="py3-pytest"
makedepends="python3-dev py3-pbr py3-setuptools"
-source="https://github.com/edio/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://github.com/edio/randrctl/archive/$pkgver/randrctl-$pkgver.tar.gz"
export PBR_VERSION="$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
pytest-3 .
}
package() {
- cd "$builddir"
-
python3 setup.py install --prefix=/usr --root="$pkgdir"
install -m 644 -D randrctl/setup/99-randrctl.rules \
"$pkgdir"/lib/udev/rules.d/99-$pkgname.rules
}
-sha512sums="f8dd2cb009853ceed588f02485a850676d163e3fce23f299b6e8db7c98c50a6c3360b531d14e3102b9a132f29e015a8a8e40ed8ecffb6340144e34e3a28f5ff6 randrctl-1.8.0.tar.gz"
+sha512sums="81b9ff948e7510208776d8a91e98fea6ddf4a7fd3470560186aaafdc0f260a39ea733d8638ff6c7e86ac33a7f6eb90c387c4009a2d6e2afad36d4e2400efe0b1 randrctl-1.8.2.tar.gz"