aboutsummaryrefslogtreecommitdiffstats
path: root/testing/range-v3
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 19:13:40 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-06 04:45:41 +0000
commit82c25ea9026121b35b51d1c36bcf665f311d7f2a (patch)
treef800042b68d3f2a0a7c0d1b766531427d9d03a5c /testing/range-v3
parent010d7fa4c9668479e240424fdce30687394b1193 (diff)
downloadaports-82c25ea9026121b35b51d1c36bcf665f311d7f2a.tar.bz2
aports-82c25ea9026121b35b51d1c36bcf665f311d7f2a.tar.xz
testing/range-v3: new aport
Diffstat (limited to 'testing/range-v3')
-rw-r--r--testing/range-v3/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/range-v3/APKBUILD b/testing/range-v3/APKBUILD
new file mode 100644
index 0000000000..4037dae927
--- /dev/null
+++ b/testing/range-v3/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=range-v3
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Experimental range library for C++11/14/17"
+url="https://github.com/ericniebler/range-v"
+arch="noarch"
+license="BSL-1.0"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ericniebler/range-v3/archive/${pkgver}.tar.gz"
+
+build() {
+ sed -i -e '/Werror/d' -e '/Wextra/d' -e '/Wall/d' cmake/ranges_flags.cmake
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux -DRANGES_NATIVE=OFF"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DRANGE_V3_EXAMPLES=OFF \
+ -DRANGE_V3_PERF=OFF \
+ -DRANGE_V3_TESTS=ON \
+ -DRANGE_BUILD_CALENDAR_EXAMPLE=OFF \
+ -DRANGES_NATIVE=ON \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8ada76e44daebe05ab59c353f8858ecacea7a4bd7618d4e75a443c02cefcc7dfa20542546eb58b5d89f043a4e86142fba963c1ce4d12ca12ef8a4cb852225aee range-v3-0.4.0.tar.gz"