aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ranger
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 16:26:32 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 20:12:10 +0000
commit49170a4234d9416d2fd87106d13d33550b022fcc (patch)
tree1649e9ee7419620ff3bb98c5ba19e906174bed16 /testing/ranger
parent8a5cf4e2e2bd1de5de4f17681ce321a9c2f0231f (diff)
downloadaports-49170a4234d9416d2fd87106d13d33550b022fcc.tar.bz2
aports-49170a4234d9416d2fd87106d13d33550b022fcc.tar.xz
testing/ranger: new aport
Diffstat (limited to 'testing/ranger')
-rw-r--r--testing/ranger/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/ranger/APKBUILD b/testing/ranger/APKBUILD
new file mode 100644
index 0000000000..2cc6a8585b
--- /dev/null
+++ b/testing/ranger/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=ranger
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="VIM-inspired filemanager for the console"
+url="https://ranger.github.io/"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ranger/ranger/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3 tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+
+ install -Dm644 doc/ranger.1 "$pkgdir"/usr/share/man/man1/ranger.1
+ install -Dm644 doc/rifle.1 "$pkgdir"/usr/share/man/man1/rifle.1
+}
+
+sha512sums="5eb4743beaf0478d745cce8e5bfc2ac07c98ab5784e9394772782d06c0bb27dcd5478ead191ac527f21cce76db09a51eb46db0fabc7993684a6b5aaec0d43104 ranger-1.9.2.tar.gz"