aboutsummaryrefslogtreecommitdiffstats
path: root/testing/raspberrypi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-21 09:00:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-11-21 09:01:41 +0000
commit57983465375010a151353c3513ed4650e92473cb (patch)
tree891835bb76f78911effc61fb14d0c1deef1197a2 /testing/raspberrypi
parent28a40b21cee915078d7cf8dcdfe6ff978c450212 (diff)
downloadaports-57983465375010a151353c3513ed4650e92473cb.tar.bz2
aports-57983465375010a151353c3513ed4650e92473cb.tar.xz
main/raspberrypi: move from testing, upgrade to latest snapshot
remove now unneeded patches. upstream supports musl.
Diffstat (limited to 'testing/raspberrypi')
-rw-r--r--testing/raspberrypi/APKBUILD64
-rw-r--r--testing/raspberrypi/fix-musl.patch49
-rw-r--r--testing/raspberrypi/fix-stdc99.patch24
3 files changed, 0 insertions, 137 deletions
diff --git a/testing/raspberrypi/APKBUILD b/testing/raspberrypi/APKBUILD
deleted file mode 100644
index 2e295e6e91..0000000000
--- a/testing/raspberrypi/APKBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Maintainer: Timo Teräs <timo.teras@iki.fi>
-pkgname=raspberrypi
-pkgver=0.20140919
-_commitid=ffcc4bd7c4875b71376c4240116e251652c9bec0
-pkgrel=0
-pkgdesc="Raspberry Pi support tools"
-url="https://github.com/raspberrypi/userland"
-arch="armhf"
-license="BSD"
-depends=""
-makedepends="cmake"
-install=""
-options="!fhs"
-subpackages="$pkgname-dev $pkgname-libs"
-source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
- fix-musl.patch
- fix-stdc99.patch
- "
-
-_sourcedir="$srcdir"/userland-$_commitid
-_builddir="$srcdir"/build
-
-prepare() {
- local i
- cd "$_sourcedir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- mkdir -p "$_builddir"
- cd "$_builddir"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_RPATH=/opt/vc/lib $_sourcedir || return 1
- make
-}
-
-package() {
- cd "$_builddir"
- make install DESTDIR="$pkgdir" || return 1
-
- # nuke the unwanted stuff
- rm -rf "$pkgdir"/opt/vc/src
- rm -rf "$pkgdir"/opt/vc/lib/*.a
-}
-
-libs() {
- pkgdesc="Raspberry Pi support libraries"
-
- mkdir -p "$subpkgdir"/opt/vc/lib
- mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
-}
-
-md5sums="6627660ea21c35859ada7d638247e049 raspberrypi-0.20140919.tar.gz
-49a33897d575a07514b1b8d288361f63 fix-musl.patch
-7da1da67742eac08b7a36b70cea6a50d fix-stdc99.patch"
-sha256sums="a9172bb498a1537dba74df5bcef67a1b83244e45282130b05fd2873c49e15ac0 raspberrypi-0.20140919.tar.gz
-e8cbc558094d745f99a14f354720be0fdf81f2ebc48651fed32c4ae1ef1fd649 fix-musl.patch
-6cd7d652073790b66760eea41042124eb5426b23a515ad6108dc4cb25b9f61b5 fix-stdc99.patch"
-sha512sums="ee50855a2fff41c07761c9f3cabdee658f72a47b71a1ad82d478bde782c7577e9280e76f8b11432a373027f0566acb4349003b654e4a6e63ec70e9b03763fe99 raspberrypi-0.20140919.tar.gz
-8092d59985d7380b533896c6f8aad6f4838e8cf414a8052c43fa4330bc07ce6be7d2d0cc3bc280f3f63b537687cb8f51c93ef608db82fe6638505d03b317581f fix-musl.patch
-1650cf7230da10d0ceedfcae170e93d2c33e799b670392a2cc1e44cf7108c9f46c47b6daa50a608bba4e1683d859d9b70eb7d2070640c956fe6c0d58a29ca89f fix-stdc99.patch"
diff --git a/testing/raspberrypi/fix-musl.patch b/testing/raspberrypi/fix-musl.patch
deleted file mode 100644
index 2460d30440..0000000000
--- a/testing/raspberrypi/fix-musl.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/interface/vcos/pthreads/vcos_platform.h b/interface/vcos/pthreads/vcos_platform.h
-index 465abd2..9356479 100755
---- a/interface/vcos/pthreads/vcos_platform.h
-+++ b/interface/vcos/pthreads/vcos_platform.h
-@@ -120,9 +120,6 @@ typedef struct
-
- #define VCOS_ONCE_INIT PTHREAD_ONCE_INIT
-
--#if defined(__arm__) && !defined(_HAVE_TIMER_T) && !defined(ANDROID)
--typedef __timer_t timer_t;
--#endif
- typedef struct VCOS_TIMER_T
- {
- pthread_t thread; /**< id of the timer thread */
-diff --git a/interface/vcos/pthreads/vcos_pthreads.c b/interface/vcos/pthreads/vcos_pthreads.c
-index 6ecc7da..9296ebe 100644
---- a/interface/vcos/pthreads/vcos_pthreads.c
-+++ b/interface/vcos/pthreads/vcos_pthreads.c
-@@ -580,7 +580,7 @@ const char ** vcos_get_argv(void)
- */
- uint32_t _vcos_get_ticks_per_second(void)
- {
-- return HZ;
-+ return 100;
- }
-
- VCOS_STATUS_T vcos_once(VCOS_ONCE_T *once_control,
-diff --git a/interface/vmcs_host/linux/vcfilesys.c b/interface/vmcs_host/linux/vcfilesys.c
-index ab65e3e..53c7486 100644
---- a/interface/vmcs_host/linux/vcfilesys.c
-+++ b/interface/vmcs_host/linux/vcfilesys.c
-@@ -49,7 +49,7 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #include <ctype.h>
- #include <limits.h>
-
--#if !defined(ANDROID) && !defined( __USE_FILE_OFFSET64 )
-+#if defined(__GLIBC__) && !defined( __USE_FILE_OFFSET64 )
- #error "__USE_FILE_OFFSET64 isn't defined"
- #endif
-
-@@ -916,7 +916,7 @@ int vc_hostfs_set_attr(const char *path, fattributes_t attr)
-
- if (pathbuf)
- {
-- __mode_t mode = 0;
-+ mode_t mode = 0;
- struct stat sb;
-
- backslash_to_slash(pathbuf);
diff --git a/testing/raspberrypi/fix-stdc99.patch b/testing/raspberrypi/fix-stdc99.patch
deleted file mode 100644
index 4cdda94c76..0000000000
--- a/testing/raspberrypi/fix-stdc99.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/containers/CMakeLists.txt
-+++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/containers/CMakeLists.txt
-@@ -13,7 +13,7 @@
-
- SET( GCC_COMPILER_FLAGS -Wall -g -O2 -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wcast-qual -Wwrite-strings -Wundef )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wextra )#-Wno-missing-field-initializers )
--SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -D__STDC_VERSION__=199901L )
-+SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -std=c99 )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-missing-field-initializers )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-unused-value )
-
---- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/interface/vcos/pthreads/vcos_platform.h
-+++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/interface/vcos/pthreads/vcos_platform.h
-@@ -44,6 +44,10 @@
- extern "C" {
- #endif
-
-+#ifndef _POSIX_C_SOURCE
-+#define _POSIX_C_SOURCE 199309L
-+#endif
-+
- #include <pthread.h>
- #include <semaphore.h>
- #include <unistd.h>