aboutsummaryrefslogtreecommitdiffstats
path: root/testing/raspi2png
diff options
context:
space:
mode:
authorMichal Artazov <michal@artazov.cz>2019-07-01 11:25:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-27 12:44:00 -0300
commitfd1a37bc663c3279603068066b74a1bec04e3287 (patch)
tree2cefa1f0a4c734fd055f3d1a3bdc97ce34fbd50e /testing/raspi2png
parent3c5259485227efeba3e39f1012f26afff0392616 (diff)
downloadaports-fd1a37bc663c3279603068066b74a1bec04e3287.tar.bz2
aports-fd1a37bc663c3279603068066b74a1bec04e3287.tar.xz
testing/raspi2png: new aport
https://github.com/AndrewFromMelbourne/raspi2png Utility to take a snapshot of the raspberry pi screen and save it as a PNG file
Diffstat (limited to 'testing/raspi2png')
-rw-r--r--testing/raspi2png/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/raspi2png/APKBUILD b/testing/raspi2png/APKBUILD
new file mode 100644
index 0000000000..2a915536e5
--- /dev/null
+++ b/testing/raspi2png/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: signageOS <dev@signageos.io>
+pkgname="raspi2png"
+pkgver="0.0.20190727"
+_commitid=5008e64ead4e1d3a6496ec98e800a695629a3a2e
+pkgrel=0
+pkgdesc="Utility to take a snapshot of the raspberry pi screen and save it as a PNG file"
+url="https://github.com/AndrewFromMelbourne/raspi2png"
+arch="armhf"
+license="MIT"
+makedepends="libpng-dev raspberrypi-dev"
+options="!check"
+source="raspi2png-$pkgver.tar.gz::https://github.com/AndrewFromMelbourne/raspi2png/archive/$_commitid.tar.gz"
+builddir="$srcdir/"$pkgname-$_commitid
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp raspi2png $pkgdir/usr/bin/raspi2png
+}
+sha512sums="8b7023f904aa96a99ef0b68714acb67c34d2e2806c8c40774fdde02f282fb54ee7eded760c4547db9add78127585aaa07fb80985c188faa130c3fc860788139a raspi2png-0.1.tar.gz"