aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ratpoison
diff options
context:
space:
mode:
authorDuncan Guthrie <dguthrie@posteo.net>2017-12-28 23:46:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-02 16:21:11 +0000
commit2a5b65245fc99d4756d8316c3deb1816d37db412 (patch)
treea2cf9bfb91112bac034ffe14fc303e2f7e51aba0 /testing/ratpoison
parentbb08ad17e0ca4521804c702508b039ab3b2ba4f2 (diff)
downloadaports-2a5b65245fc99d4756d8316c3deb1816d37db412.tar.bz2
aports-2a5b65245fc99d4756d8316c3deb1816d37db412.tar.xz
testing/ratpoison: new aport
Diffstat (limited to 'testing/ratpoison')
-rw-r--r--testing/ratpoison/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/ratpoison/APKBUILD b/testing/ratpoison/APKBUILD
new file mode 100644
index 0000000000..2671f4408c
--- /dev/null
+++ b/testing/ratpoison/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Duncan Guthrie <dguthrie@posteo.net>
+# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
+pkgname=ratpoison
+pkgver=1.4.9
+pkgrel=0
+pkgdesc="ratpoison: Say good-bye to the rodent"
+url="http://ratpoison.nongnu.org"
+arch="all"
+license="GPL2"
+depends="libx11"
+makedepends="libx11-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-xkb \
+ --without-xft \
+ --without-xrandr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="97f705efd2092b8e12528496890c59f613e6fcec010aca94a5a59bd641e22dfc50dd500a4b94af7a07553a8a6359f6bec4eee0db1a7ded29d7f051904b09beef ratpoison-1.4.9.tar.xz"