aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rdedup
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-09-26 23:56:18 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-27 09:10:33 +0200
commit6d13e33810edfd9b5d12b0b8f7bc1bcf73f43f5e (patch)
tree3e94f54d3581efb9d91536d14ef98926053de04e /testing/rdedup
parenta9cb9cd8381645943b916cb67011b217a1df694f (diff)
downloadaports-6d13e33810edfd9b5d12b0b8f7bc1bcf73f43f5e.tar.bz2
aports-6d13e33810edfd9b5d12b0b8f7bc1bcf73f43f5e.tar.xz
testing/rdedup: add more arches and fix license
Diffstat (limited to 'testing/rdedup')
-rw-r--r--testing/rdedup/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/rdedup/APKBUILD b/testing/rdedup/APKBUILD
index d62146e413..72862e799a 100644
--- a/testing/rdedup/APKBUILD
+++ b/testing/rdedup/APKBUILD
@@ -5,12 +5,19 @@ pkgver="3.1.1"
pkgrel=1
pkgdesc="Data deduplication with compression and public key encryption"
url="https://github.com/dpc/rdedup"
-arch="x86_64 armhf armv7" # limited by cargo
+arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by cargo
license="MPL-2.0"
makedepends="cargo clang-dev libsodium-dev openssl-dev xz-dev"
source="https://github.com/dpc/${pkgname}/archive/${pkgname}-v${pkgver}.tar.gz"
builddir="$srcdir/${pkgname}-${pkgname}-v${pkgver}"
+# disable stack protector on x86 due linking error in cc package
+case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+esac
+
_cargo_env() {
cd "$builddir"