aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rdedup
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-11 18:42:05 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-12 05:49:54 +0000
commit3d20babc682152a06c5c1a6df7d0567e91bbd3b7 (patch)
tree2519444a7b645d96180eff7c6f5dfb11d9747ad3 /testing/rdedup
parente7b257acce5eb15e013ebfefd57961aa1ef6d8cf (diff)
downloadaports-3d20babc682152a06c5c1a6df7d0567e91bbd3b7.tar.bz2
aports-3d20babc682152a06c5c1a6df7d0567e91bbd3b7.tar.xz
testing/rdedup: new aport
https://github.com/dpc/rdedup Data deduplication with compression and public key encryption
Diffstat (limited to 'testing/rdedup')
-rw-r--r--testing/rdedup/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/rdedup/APKBUILD b/testing/rdedup/APKBUILD
new file mode 100644
index 0000000000..a9ae0e4691
--- /dev/null
+++ b/testing/rdedup/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: tcely <rdedup+aports@tcely.33mail.com>
+# Maintainer: tcely <rdedup+aports@tcely.33mail.com>
+pkgname="rdedup"
+pkgver="3.1.1"
+pkgrel=0
+pkgdesc="Data deduplication with compression and public key encryption"
+url="https://github.com/dpc/rdedup"
+arch="x86_64" # limited by cargo
+license="MPL-2.0"
+depends=""
+makedepends="cargo clang-dev libsodium-dev openssl-dev xz-dev"
+install=""
+subpackages=""
+source="https://github.com/dpc/${pkgname}/archive/${pkgname}-v${pkgver}.tar.gz"
+builddir="$srcdir/${pkgname}-${pkgname}-v${pkgver}"
+
+_cargo_env() {
+ cd "$builddir"
+
+ RELEASE=true
+ export RELEASE
+}
+
+build() {
+ _cargo_env
+
+ make check build
+}
+
+check() {
+ _cargo_env
+
+ make bench test
+}
+
+package() {
+ _cargo_env
+
+ cargo install --root "$pkgdir" --path "$builddir"
+}
+
+sha512sums="f94fc99ce84f5618ec5e24f48c593e7644eecadc4be2d997f9847576d97f3c5adf97a97fca1376ea0da4e24b9acf7cee354e032e6354a07a9922c63f798426ae rdedup-v3.1.1.tar.gz"