aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-11-14 10:32:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-11-14 10:32:30 +0000
commitdeab96c6016be38ab793c6ad0c4f8227d0984235 (patch)
tree889fbb3ad54ba4aa69b2fef8df913fdac6e242e0 /testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch
parente8603102422b6e0be62d51fabaeec2bc1acc19fc (diff)
downloadaports-deab96c6016be38ab793c6ad0c4f8227d0984235.tar.bz2
aports-deab96c6016be38ab793c6ad0c4f8227d0984235.tar.xz
testing/reaver-wps-fork-t6x: new aport. Fixes #6459
Diffstat (limited to 'testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch')
-rw-r--r--testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch b/testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch
new file mode 100644
index 0000000000..842993553d
--- /dev/null
+++ b/testing/reaver-wps-fork-t6x/0200-makefile-path-fix.patch
@@ -0,0 +1,19 @@
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 76ec142..1911ac2 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -85,10 +85,10 @@ globule.o:
+ $(CC) $(CFLAGS) globule.c -c
+
+ install: cleanbin
+- if [ ! -d $(CONFDIR) ]; then mkdir -p $(CONFDIR); fi
+- if [ ! -e $(CONFDIR)/reaver.db ]; then cp reaver.db $(CONFDIR)/reaver.db && chmod -R a+rw $(CONFDIR); fi
+- if [ -e wash ]; then cp wash @bindir@/wash; fi
+- if [ -e reaver ]; then cp reaver @bindir@/reaver; fi
++ if [ ! -d $(CONFDIR) ]; then mkdir -p $(DESTDIR)$(CONFDIR); fi
++ if [ ! -e $(CONFDIR)/reaver.db ]; then cp reaver.db $(DESTDIR)$(CONFDIR)/reaver.db && chmod -R a+rw $(DESTDIR)$(CONFDIR); fi
++ if [ -e wash ]; then cp wash $(DESTDIR)@bindir@/wash; fi
++ if [ -e reaver ]; then cp reaver $(DESTDIR)@bindir@/reaver; fi
+
+ clean:
+ rm -f *~ *.o reaver wash