aboutsummaryrefslogtreecommitdiffstats
path: root/testing/redo
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-01-13 17:14:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-16 20:16:10 +0000
commitf9be3d95bd93422e4594f317e658ecf91c39a659 (patch)
tree2e36e8e45def12845b9f62d5ff9fb3c831609887 /testing/redo
parente01acd2d2c8c7f316974658f2d3fd171bd12d4d0 (diff)
downloadaports-f9be3d95bd93422e4594f317e658ecf91c39a659.tar.bz2
aports-f9be3d95bd93422e4594f317e658ecf91c39a659.tar.xz
testing/redo: new aport
Diffstat (limited to 'testing/redo')
-rw-r--r--testing/redo/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/redo/APKBUILD b/testing/redo/APKBUILD
new file mode 100644
index 0000000000..51d588330b
--- /dev/null
+++ b/testing/redo/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=redo
+pkgver=0.41
+pkgrel=0
+pkgdesc="Smaller, easier, more powerful, and more reliable than make"
+url="https://redo.readthedocs.io/en/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="python2"
+makedepends="python2 perl"
+subpackages="$pkgname-doc"
+source="https://github.com/apenwarr/redo/archive/redo-${pkgver}.tar.gz"
+builddir="$srcdir/redo-redo-${pkgver}"
+
+build() {
+ cd "$builddir"
+
+ ./do build
+}
+
+check() {
+ cd "$builddir"
+ ./do test
+
+ # Some files / directories are created as read-only for testing
+ # purposes. Make them writable again to make sure we can remove them
+ # again.
+ chmod -R +w .
+}
+
+package() {
+ cd "$builddir"
+
+ DESTDIR="$pkgdir" PREFIX="/usr" ./do install
+}
+
+sha512sums="94e4414a2f8120e5d4a949461734ed69dc2f39edfb7929d2efff83041ac0b941e037359ccfafcb4eff760608274e32c579df56d58fdb67b13b8a26eb1945b0d0 redo-0.41.tar.gz"