aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reprotest
diff options
context:
space:
mode:
authorAntoine Fontaine <antoine.fontaine@epfl.ch>2019-12-06 16:56:06 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-30 23:38:35 +0100
commit732825c18c3525c5d501311650d488bb51ceb62e (patch)
tree3365bb70dbe53faaa0a92ec465d06697790ceaf2 /testing/reprotest
parent8fbb853c51b7e72dc353adf241d9b73fd2cd8e7f (diff)
downloadaports-732825c18c3525c5d501311650d488bb51ceb62e.tar.bz2
aports-732825c18c3525c5d501311650d488bb51ceb62e.tar.xz
testing/reprotest: new aport
Diffstat (limited to 'testing/reprotest')
-rw-r--r--testing/reprotest/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/reprotest/APKBUILD b/testing/reprotest/APKBUILD
new file mode 100644
index 0000000000..d051826632
--- /dev/null
+++ b/testing/reprotest/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname="reprotest"
+_pyname="reprotest"
+pkgver="0.7.8"
+pkgrel=0
+pkgdesc="Build packages and check them for reproducibility"
+url="https://salsa.debian.org/reproducible-builds/reprotest"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3"
+makedepends="make py3-setuptools py3-wheel"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="ba35e6e6dba05c290d7b770813846e38e5aadfd0e5cd8a9efcea0dd0a0a668e403cd0f85d090e115b1bb174607de2c6656efce8fd7d8251295e721384a330253 reprotest-0.7.8.tar.gz"