aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rocksdb/10-support-busybox-install.patch
diff options
context:
space:
mode:
authorJames Bowes <jbowes@repl.ca>2016-02-15 16:40:24 -0400
committerTimo Teräs <timo.teras@iki.fi>2016-02-22 14:24:03 +0000
commit7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65 (patch)
tree7342345830bf0af5a86ca48a2e1843a6a8322675 /testing/rocksdb/10-support-busybox-install.patch
parent0b87fe1b7d417dad80a48b3d7743c37cf47cb943 (diff)
downloadaports-7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65.tar.bz2
aports-7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65.tar.xz
testing/rocksdb: new aport
http://rocksdb.org A persistent key-value store for fast storage environments
Diffstat (limited to 'testing/rocksdb/10-support-busybox-install.patch')
-rw-r--r--testing/rocksdb/10-support-busybox-install.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/rocksdb/10-support-busybox-install.patch b/testing/rocksdb/10-support-busybox-install.patch
new file mode 100644
index 0000000000..8974dfa9a0
--- /dev/null
+++ b/testing/rocksdb/10-support-busybox-install.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -996,14 +996,14 @@ install-headers:
+ install -d $(INSTALL_PATH)/$$header_dir; \
+ done
+ for header in `find "include/rocksdb" -type f -name *.h`; do \
+- install -C -m 644 $$header $(INSTALL_PATH)/$$header; \
++ install -c -m 644 $$header $(INSTALL_PATH)/$$header; \
+ done
+
+ install-static: install-headers $(LIBRARY)
+- install -C -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
++ install -c -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
+
+ install-shared: install-headers $(SHARED4)
+- install -C -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
++ install -c -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED3) && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED2) && \
+ ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED1)