aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rocs
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-03 16:13:22 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-03 11:23:03 -0300
commit3dec24187a14e93cabc3ffaa3b124ecf1bdb0456 (patch)
tree72eb3f285788457cb59d427fbb85b993cd67b552 /testing/rocs
parent776c02734f23cd174e3c637781c989474ab2e15a (diff)
downloadaports-3dec24187a14e93cabc3ffaa3b124ecf1bdb0456.tar.bz2
aports-3dec24187a14e93cabc3ffaa3b124ecf1bdb0456.tar.xz
testing/rocs: new aport
Diffstat (limited to 'testing/rocs')
-rw-r--r--testing/rocs/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/rocs/APKBUILD b/testing/rocs/APKBUILD
new file mode 100644
index 0000000000..ab328692df
--- /dev/null
+++ b/testing/rocs/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=rocs
+pkgver=19.08.0
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/education/org.kde.rocs"
+pkgdesc="Graph Theory IDE"
+license="GPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebkit-dev qt5-qtsvg-dev qt5-qtxmlpatterns-dev karchive-dev kconfig-dev kcoreaddons-dev kcrash-dev kdeclarative-dev ki18n-dev kitemviews-dev ktexteditor-dev kxmlgui-dev kdoctools-dev boost-dev grantlee-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/applications/$pkgver/src/rocs-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ # TestTgfFileFormat, TestRocs1FileFormat, TestRocs2FileFormat, and
+ # graphtheory-test_graphoperations are broken
+ # TestProject requires OpenGL
+ local skipped_tests="("
+ local tests="
+ TestTgfFileFormat
+ TestRocs1FileFormat
+ TestRocs2FileFormat
+ graphtheory-test_graphoperations
+ TestProject"
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)"
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "$skipped_tests"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="918fea2a0d63c19e43e05f74b76a75fa9eb1386e26b8f325c200e470290b05c570146a3d98f1e3ca4dd6b564c77f0b8bd12fb3e671863580a8b9bcc952246b54 rocs-19.08.0.tar.xz"