aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rofi
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-29 23:02:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-30 19:20:20 -0300
commitc3ca33004dd60710fcabf1cd41b32de805cf333c (patch)
tree31b186ad476be819c2958518d4fc494e35ba71ad /testing/rofi
parent03799b34b949fb2dff431dbdf85d81544fd0acc7 (diff)
downloadaports-c3ca33004dd60710fcabf1cd41b32de805cf333c.tar.bz2
aports-c3ca33004dd60710fcabf1cd41b32de805cf333c.tar.xz
testing/rofi: upgrade to 1.5.4
Diffstat (limited to 'testing/rofi')
-rw-r--r--testing/rofi/APKBUILD37
-rw-r--r--testing/rofi/scrollbar-test.patch28
2 files changed, 48 insertions, 17 deletions
diff --git a/testing/rofi/APKBUILD b/testing/rofi/APKBUILD
index cf69a3a5bc..e7223e4625 100644
--- a/testing/rofi/APKBUILD
+++ b/testing/rofi/APKBUILD
@@ -1,36 +1,39 @@
# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
pkgname=rofi
-pkgver=1.5.3
+pkgver=1.5.4
pkgrel=0
pkgdesc="A window switcher, application launcher and dmenu replacement"
url="https://github.com/DaveDavenport/rofi"
arch="all"
license="MIT"
-makedepends="bash bison cairo-dev flex glib-dev i3wm-dev librsvg-dev libxcb-dev
- libxkbcommon-dev pango-dev startup-notification-dev xcb-util-dev
- xcb-util-wm-dev xcb-util-xrm-dev"
-checkdepends="check-dev xkeyboard-config"
+makedepends="meson bison flex pangomm-dev pango-dev libxcb-dev xcb-util-dev
+ xcb-util-wm-dev xcb-util-xrm-dev glib-dev cairo-dev libxkbcommon-dev
+ librsvg-dev startup-notification-dev ronn"
+checkdepends="cppcheck xkeyboard-config"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/davatorium/rofi/releases/download/$pkgver/rofi-$pkgver.tar.xz"
+source="https://github.com/davatorium/rofi/releases/download/$pkgver/rofi-$pkgver.tar.gz
+ scrollbar-test.patch
+ "
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
}
check() {
- make check
+ ninja -C output test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="6dc4b3c2818f4606e42e8185032788d40c4dae9e67596b3b7f767e8f6ca2963b85602baa4287474520ecdb8e333ae211fce5e7252f3b95e0f90b862040aad117 rofi-1.5.3.tar.xz"
+sha512sums="181dedb0905bfab76f7ad313d299f4c80ee4efb11a2c6345b16044b7fb3f54bc7e304ee9352e562932e55108e328e5f6bd2c1d7fd9bcdec3d8022c2dc4f8d394 rofi-1.5.4.tar.gz
+2edf85133c4ce1817a37ea480913725ff086bc570bcac7ea5100d7516dce816ba6471e530a1d979fbaf0d68ce2d4e4e7ddc9c32f238c2ac2db95fde98f62a44e scrollbar-test.patch"
diff --git a/testing/rofi/scrollbar-test.patch b/testing/rofi/scrollbar-test.patch
new file mode 100644
index 0000000000..cb480a7bce
--- /dev/null
+++ b/testing/rofi/scrollbar-test.patch
@@ -0,0 +1,28 @@
+diff --git a/meson.build b/meson.build
+index db764c7..c1d29e9 100644
+--- a/meson.build
++++ b/meson.build
+@@ -328,22 +328,6 @@ test('box test', executable('box.test', [
+ dependencies: deps,
+ ))
+
+-test('scrollbar test', executable('scrollbar.test', [
+- 'test/scrollbar-test.c',
+- theme_parser,
+- theme_lexer,
+- ],
+- objects: rofi.extract_objects([
+- 'source/widgets/widget.c',
+- 'source/widgets/scrollbar.c',
+- 'source/theme.c',
+- 'source/rofi-types.c',
+- 'source/css-colors.c',
+- 'config/config.c',
+- ]),
+- dependencies: deps,
+-))
+-
+ test('textbox test', executable('textbox.test', [
+ 'test/textbox-test.c',
+ theme_parser,
+