aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-08 14:07:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-09 15:41:28 +0200
commit997883d3a0f8c8c4a12b55f62643a26883d14507 (patch)
treecfe11e2dc1c0752c2c2a7abe2523d74e922cc2e7 /testing/rust/APKBUILD
parent9345f4e5b2cf8b19131734a79f41a7936b015dca (diff)
downloadaports-997883d3a0f8c8c4a12b55f62643a26883d14507.tar.bz2
aports-997883d3a0f8c8c4a12b55f62643a26883d14507.tar.xz
testing/rust: add missing dependency on gcc
Diffstat (limited to 'testing/rust/APKBUILD')
-rw-r--r--testing/rust/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 8dee3c1677..e7bbe856d9 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -7,7 +7,10 @@ pkgdesc="The Rust Programming Language (compiler)"
url="http://www.rust-lang.org"
arch="x86_64"
license="ASL-2.0 BSD MIT"
-depends="$pkgname-stdlib"
+# gcc is needed at runtime just for linking. Someday rustc might invoke
+# the linker directly, and then we'll only need binutils.
+# See: https://github.com/rust-lang/rust/issues/11937
+depends="$pkgname-stdlib gcc"
# libffi-dev is needed just because we compile llvm3.7 with LLVM_ENABLE_FFI.
makedepends="cmake file libffi-dev llvm3.7 llvm3.7-dev llvm3.7-static
musl-dev python2 tar zlib-dev"