aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-13 15:59:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-13 16:01:58 +0200
commita552535009f808f093ecc0f614045623b13e1e51 (patch)
treedf36895f22db2b2aafc0ad504781282fdbf91241 /testing/rust
parentd455428dfa7ce90b979620546f53f4f172edee76 (diff)
downloadaports-a552535009f808f093ecc0f614045623b13e1e51.tar.bz2
aports-a552535009f808f093ecc0f614045623b13e1e51.tar.xz
testing/rust: refactor patches for linux_musl_base.rs
Diffstat (limited to 'testing/rust')
-rw-r--r--testing/rust/APKBUILD4
-rw-r--r--testing/rust/fix-linux_musl_base.patch3
-rw-r--r--testing/rust/musl-dynamic-linking-by-default.patch16
3 files changed, 20 insertions, 3 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index d11f3bcb32..bf64d6d8c8 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -33,6 +33,7 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
allow-crt-static-on-stable.patch
static-pie.patch
fix-linux_musl_base.patch
+ musl-dynamic-linking-by-default.patch
llvm-with-ffi.patch
move-py-scripts-to-share.patch
change-rpath-to-rustlib.patch
@@ -187,7 +188,8 @@ e9b10d58ae5b51b09dd31a1dbf7367917bd40a05ecb4ba3e0e7ac229a0352d3ceb77de80f7c0120f
b0a8883e4469b60edd150c84486ab950396d757220f97bd271529576614c6c3b49456098507503832c20619d4bd74246dbc99c78116634a68a6df994793e9a94 support-dynamically-linked-musl.patch
b00997c65d1a451fafae8b547893c5cbf03f028d2d70f6971aa670f34c2d6fc82728c740ac4a9909fc1999925ff300e4525cfec745cb9c9521e564eb166872a2 allow-crt-static-on-stable.patch
79d7eb79bb5219beab2fa8394e30b830275ce3062fd7c02077229ad1fdca492f55d321e0bc1015f62252fe4df3cc41c5168ff9d2e848ae06b14f807add7e193a static-pie.patch
-5813ac0373cb550fff2a99f650a50852088e6f3cd0803edf77b1f1bfa712eb3da5d7579cfe6e00f1d06750b248a5c86d0fff17dc70a31b1520a6430adc64bceb fix-linux_musl_base.patch
+f436fddf7ab70ca5f1424081f5b75450270b200b3d997231323863e11addf76e1d65831a7ca09e3a5b7904ce828766c1f70b08326a175890298f28e5bc8646ef fix-linux_musl_base.patch
+44f3104f506531778fede64034ff5b86f782744d7fed26b393cd88590c22b7fd1df441e2c14bb44c660c54140a4093686aa35f53357f9cd795af6cfa6df1cec4 musl-dynamic-linking-by-default.patch
37416e1fa0bc0c8651cd060a645d6245ff7e2082279ab5e13495c5ee412c71915469019cfbec95a0fd9a7fc144475079a3ad16f0eba7a2f5c8dd99e0002f3225 llvm-with-ffi.patch
19cc2725d68db3e359e0e3016028374e5818a97fdba24d0103f7d1706601c8b17c4dd95a3152e64f982f98e95ad3e949acddbea8a39ed0ba8dd4f702acc2704d move-py-scripts-to-share.patch
8d6206f8c50856724cf7b4c1854ec82547f040358a1c7d44abeacc27a5c205a963b1fec51e58ec06c68d85bd2f68a9e6e27ebe457f39e8dd043de17758f5063f change-rpath-to-rustlib.patch
diff --git a/testing/rust/fix-linux_musl_base.patch b/testing/rust/fix-linux_musl_base.patch
index 952d871667..38194290cb 100644
--- a/testing/rust/fix-linux_musl_base.patch
+++ b/testing/rust/fix-linux_musl_base.patch
@@ -57,8 +57,7 @@ See https://github.com/rust-lang/rust/pull/40113
- base.post_link_objects.push("crtn.o".to_string());
-
// Except for on MIPS, these targets statically link libc by default.
-- base.crt_static_default = true;
-+ base.crt_static_default = false;
+ base.crt_static_default = true;
base
}
diff --git a/testing/rust/musl-dynamic-linking-by-default.patch b/testing/rust/musl-dynamic-linking-by-default.patch
new file mode 100644
index 0000000000..225fc2df06
--- /dev/null
+++ b/testing/rust/musl-dynamic-linking-by-default.patch
@@ -0,0 +1,16 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Thu, 13 Apr 2017 15:57:00 +0200
+Subject: [PATCH] Use dynamic linking as default on musl
+
+--- a/src/librustc_back/target/linux_musl_base.rs
++++ b/src/librustc_back/target/linux_musl_base.rs
+@@ -19,9 +19,6 @@
+ // argument is *not* necessary for normal builds, but it can't hurt!
+ base.pre_link_args.push("-Wl,--eh-frame-hdr".to_string());
+
+- // Except for on MIPS, these targets statically link libc by default.
+- base.crt_static_default = true;
+-
+ // Static position-independent executables are supported.
+ base.static_position_independent_executables = true;
+