aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rutorrent
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:58:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:58:29 +0000
commit07f036da43f6f5c372a3fdc0e67ee4535ef0125e (patch)
tree108cf04c89d1b0a5e5869cbba3397c8c8ae8cc82 /testing/rutorrent
parent27563f5bfee734648c82e9e9a8e19a7fe545e7fe (diff)
downloadaports-07f036da43f6f5c372a3fdc0e67ee4535ef0125e.tar.bz2
aports-07f036da43f6f5c372a3fdc0e67ee4535ef0125e.tar.xz
community/rutorrent: moved from testing
Diffstat (limited to 'testing/rutorrent')
-rw-r--r--testing/rutorrent/APKBUILD42
-rw-r--r--testing/rutorrent/rutorrent.post-install26
-rw-r--r--testing/rutorrent/rutorrent.pre-install5
3 files changed, 0 insertions, 73 deletions
diff --git a/testing/rutorrent/APKBUILD b/testing/rutorrent/APKBUILD
deleted file mode 100644
index 738cd8fc65..0000000000
--- a/testing/rutorrent/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=rutorrent
-pkgver=3.7
-pkgrel=2
-pkgdesc="Yet another web front-end for rTorrent"
-url="http://code.google.com/p/rutorrent/"
-arch="noarch"
-license="GPL"
-depends="php5 curl"
-depends_dev=""
-
-# we need to user gnu tar since the permissions on files in tar archive are
-# bad
-makedepends="tar"
-
-pkggroups="rutorrent"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages=""
-source="http://dl.bintray.com/novik65/generic/ruTorrent-$pkgver.zip"
-_builddir="$srcdir"/ruTorrent-master
-
-
-build() {
- cd "$_builddir"
- chmod -R u+w "$_builddir"
-}
-
-package() {
- cd "$_builddir"
- install -d $pkgdir/usr/share/webapps/$pkgname
- install -d $pkgdir/var/www/localhost/htdocs/
- cp -r * $pkgdir/usr/share/webapps/$pkgname
- chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
-}
-
-md5sums="8ef91254d5bbf45da3e1d1962b6fe8e7 ruTorrent-3.7.zip"
-sha256sums="c1fb86317231c8e8fa9e1a7dea450ce4687d94caad22d763bc68d90c56d0749f ruTorrent-3.7.zip"
-sha512sums="b8e1173e39f90c21903f3f5cc39377fb7a874bd2023130f4ffba6927ed85583c7934709eea130b1871f217f873c888fc42d53a0f9bb3ee4397f01b3aff850660 ruTorrent-3.7.zip"
diff --git a/testing/rutorrent/rutorrent.post-install b/testing/rutorrent/rutorrent.post-install
deleted file mode 100644
index 05ce03e90c..0000000000
--- a/testing/rutorrent/rutorrent.post-install
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-ln -s /usr/share/webapps/rutorrent /var/www/localhost/htdocs/rutorrent 2>/dev/null
-echo "*" >&2
-echo "* rutorrent has been installed to: " >&2
-echo "* /usr/share/webapps/rutorrent " >&2
-echo "* If you use lighttpd: " >&2
-echo "* 1 - enable mod_scgi in lighttpd.conf adding: " >&2
-echo "* server.modules += ( "mod_scgi" ) " >&2
-echo "* 2 - touch /etc/lighttpd/mod_scgi.conf " >&2
-echo "* 3 - add the following entry in mod_scgi.conf: " >&2
-echo "* scgi.server =( " >&2
-echo "* "/RPC1" => " >&2
-echo "* ( "127.0.0.1" => " >&2
-echo "* ( " >&2
-echo "* "host" => "127.0.0.1", " >&2
-echo "* "port" => 5000, " >&2
-echo "* "check-local" => "disable" " >&2
-echo "* ) " >&2
-echo "* ) " >&2
-echo "* ) " >&2
-echo "* 4 - (optional) Add lighttpd to rutorrent group " >&2
-echo "* to give to webserver r/w permissions on rutorrent " >&2
-echo "* share folder (/usr/share/webapps/rutorrent/share): " >&2
-echo "* addgroup lighttpd rutorrent " >&2
-echo "*" >&2
-exit 0
diff --git a/testing/rutorrent/rutorrent.pre-install b/testing/rutorrent/rutorrent.pre-install
deleted file mode 100644
index 2c539f62fd..0000000000
--- a/testing/rutorrent/rutorrent.pre-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-addgroup -S rutorrent 2>/dev/null
-
-exit 0