aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sbcl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-11 20:51:27 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-12 12:59:30 +0200
commita9235ec02053befdb7dc4e2aabe06a152ba0c3b0 (patch)
tree4c9f3ecd36a12e426adefb0f8bd8ed81b557805c /testing/sbcl
parent671289c0477cf2484554a9d1d5f1898db57fbe73 (diff)
downloadaports-a9235ec02053befdb7dc4e2aabe06a152ba0c3b0.tar.bz2
aports-a9235ec02053befdb7dc4e2aabe06a152ba0c3b0.tar.xz
testing/sbcl: improve abuild
Diffstat (limited to 'testing/sbcl')
-rw-r--r--testing/sbcl/APKBUILD20
-rw-r--r--testing/sbcl/sbcl_prefix.patch11
2 files changed, 21 insertions, 10 deletions
diff --git a/testing/sbcl/APKBUILD b/testing/sbcl/APKBUILD
index 5d493ec981..113c52b1cc 100644
--- a/testing/sbcl/APKBUILD
+++ b/testing/sbcl/APKBUILD
@@ -7,23 +7,20 @@ pkgdesc="Steel Bank Common Lisp"
url="http://www.sbcl.org/"
arch="x86_64"
license="custom"
-depends=""
-depends_dev=""
-makedepends="zlib-dev clisp paxmark linux-headers"
-install=""
+makedepends="clisp linux-headers paxmark zlib-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.bz2::http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver-source.tar.bz2
pax-genesis-stage-two.patch
ignore-test-failure.patch
musl-fixes.patch
- config"
+ sbcl_prefix.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
- cp "$srcdir"/config "$builddir"/customize-target-features.lisp
- sed -i 's@SBCL_PREFIX=\"/usr/local\"@SBCL_PREFIX=\"/usr\"@' make-config.sh
+ cp "$srcdir"/config "$builddir"/customize-target-features.lisp
}
build() {
@@ -33,11 +30,14 @@ build() {
package() {
cd "$builddir"
- INSTALL_ROOT="$pkgdir/usr" LIB_DIR="/usr/lib" \
+
+ INSTALL_ROOT="$pkgdir/usr" \
+ LIB_DIR="/usr/lib" \
DOC_DIR="$pkgdir/usr/share/doc/$pkgname" \
sh install.sh
paxmark -rm "$pkgdir"/usr/bin/sbcl
+
install -Dm644 COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
@@ -49,4 +49,4 @@ sha512sums="e0248f460f9737d47653dd520732062d2637813b550df356ecc90aa6d21fbdd74f03
cda5c7268b314145a1bdb8293c7970e077aebf3cce5dace12542bf18beb7b124bf97f4754906f2f681428869ca3060300b88cab80055a3d5881dfcdcfbe51d6d pax-genesis-stage-two.patch
fcaf0754084d705b263cbca20988e2cacc96470d4f0f2e15b812678ba8d15a43de2b3ebd87648f6540833615fdbde0011f72ce7800b02dcbd8055229eb439ec3 ignore-test-failure.patch
19bb9dac5997366c9778e349b707970832c5020ac55f0099dd652a8cc8c43336d34a33db2e4f7f190ab8212b064718f6999b832c249a4de7d24eae2186d6acea musl-fixes.patch
-03516a49ae8753e254a0a3fa48429d796ffacbc08360d8a41563cf8e3c3fe7fd6989021be6733549460bd78575cd5267fab9315dec53b16f5c349a990f4597dc config"
+bfb6bef3b6512e487e45bc8c9cf36aa519e470690b6c7036bba7d28269bd899c60a4dfa09b5aba44830b8c002e7191276f2cf6f8f134b163d05af7b46f9849ff sbcl_prefix.patch"
diff --git a/testing/sbcl/sbcl_prefix.patch b/testing/sbcl/sbcl_prefix.patch
new file mode 100644
index 0000000000..2019d0e7ec
--- /dev/null
+++ b/testing/sbcl/sbcl_prefix.patch
@@ -0,0 +1,11 @@
+--- a/make-config.sh
++++ b/make-config.sh
+@@ -30,7 +30,7 @@
+ then
+ SBCL_PREFIX="$PROGRAMFILES/sbcl"
+ else
+- SBCL_PREFIX="/usr/local"
++ SBCL_PREFIX="/usr"
+ fi
+ SBCL_XC_HOST="sbcl --no-userinit --no-sysinit"
+ export SBCL_XC_HOST