aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sbcl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-12 01:06:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-12 12:59:30 +0200
commit54a4689ec78fafa6c6a7926d8d26d20f05a2bf7b (patch)
tree5c105e887e028d8416b842626ed95b1d25413d59 /testing/sbcl
parenta9235ec02053befdb7dc4e2aabe06a152ba0c3b0 (diff)
downloadaports-54a4689ec78fafa6c6a7926d8d26d20f05a2bf7b.tar.bz2
aports-54a4689ec78fafa6c6a7926d8d26d20f05a2bf7b.tar.xz
testing/sbcl: use make.sh flags instead of config file
Diffstat (limited to 'testing/sbcl')
-rw-r--r--testing/sbcl/APKBUILD14
-rw-r--r--testing/sbcl/config8
2 files changed, 7 insertions, 15 deletions
diff --git a/testing/sbcl/APKBUILD b/testing/sbcl/APKBUILD
index 113c52b1cc..e819212e03 100644
--- a/testing/sbcl/APKBUILD
+++ b/testing/sbcl/APKBUILD
@@ -17,15 +17,15 @@ source="$pkgname-$pkgver.tar.bz2::http://prdownloads.sourceforge.net/$pkgname/$p
"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- cp "$srcdir"/config "$builddir"/customize-target-features.lisp
-}
-
build() {
cd "$builddir"
- GNUMAKE=make ./make.sh "clisp" --prefix=/usr
+
+ GNUMAKE=make ./make.sh clisp \
+ --prefix=/usr \
+ --without-sb-thread \
+ --without-sb-test \
+ --with-sb-unicode \
+ --with-sb-core-compression
}
package() {
diff --git a/testing/sbcl/config b/testing/sbcl/config
deleted file mode 100644
index e312bb72d2..0000000000
--- a/testing/sbcl/config
+++ /dev/null
@@ -1,8 +0,0 @@
-(lambda (list)
- (flet ((enable (x) (pushnew x list))
- (disable (x) (setf list (remove x list))))
- (disable :sb-thread)
- (disable :sb-test)
- (enable :sb-unicode)
- (enable :sb-core-compression))
- list)