aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sblim-sfcc
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-03-16 17:59:51 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-03-16 17:59:51 +0000
commit9b89f989b762ed0bf6dba85a3abd5b628894dc53 (patch)
tree7b027c1c9c42b5729bd29b21a94b527c914dc31c /testing/sblim-sfcc
parent2bf616a212d4a57e21f5bc61bec35401ca4936b1 (diff)
downloadaports-9b89f989b762ed0bf6dba85a3abd5b628894dc53.tar.bz2
aports-9b89f989b762ed0bf6dba85a3abd5b628894dc53.tar.xz
testing/sblim-sfcc: new aport
Diffstat (limited to 'testing/sblim-sfcc')
-rw-r--r--testing/sblim-sfcc/APKBUILD36
-rw-r--r--testing/sblim-sfcc/sockaddr-arg.patch13
-rw-r--r--testing/sblim-sfcc/time-struct.patch13
3 files changed, 62 insertions, 0 deletions
diff --git a/testing/sblim-sfcc/APKBUILD b/testing/sblim-sfcc/APKBUILD
new file mode 100644
index 0000000000..070b61c483
--- /dev/null
+++ b/testing/sblim-sfcc/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=sblim-sfcc
+pkgver=2.2.8
+pkgrel=0
+pkgdesc="Small Footprint CIM Client Library"
+url="http://sourceforge.net/projects/sblim"
+arch="all"
+license="EPL-1.0"
+depends="curl"
+makedepends="curl-dev linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/sblim/$pkgname/$pkgname-$pkgver.tar.bz2
+ time-struct.patch
+ sockaddr-arg.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b5eb7712aed1e40f19993ba5f5ee2f1f48c01246d28e9f4d89cee53000801ce4fe7c862a82163a55774c71094223b32bf8981a883ad04e820f9c749e746f52fa sblim-sfcc-2.2.8.tar.bz2
+624d8e198ac2801bcb0d137aa927619e29892def0f8bca28c65b1c48390ebe5ce1d3f2ab29f2e99ec29d5790158368579ee075fe9d3414aba1ef1ed69f8d0923 time-struct.patch
+f92b4b0bfe75a46728279882123dabba2fe2c7932982ab29e6e827741c22153fb34024d17007171ba1faeb455f7a09846b1e8f3fe8fdff0ff7a5890dd162377b sockaddr-arg.patch"
diff --git a/testing/sblim-sfcc/sockaddr-arg.patch b/testing/sblim-sfcc/sockaddr-arg.patch
new file mode 100644
index 0000000000..03b1bf75d8
--- /dev/null
+++ b/testing/sblim-sfcc/sockaddr-arg.patch
@@ -0,0 +1,13 @@
+diff --git a/backend/cimxml/indicationlistener.c b/backend/cimxml/indicationlistener.c
+index 0d7d9fe..3be0bb7 100755
+--- a/backend/cimxml/indicationlistener.c
++++ b/backend/cimxml/indicationlistener.c
+@@ -36,7 +36,7 @@ static int do_listen=1;
+ #define hdrBufsize 5000
+ #define hdrLimmit 5000
+
+-#ifdef __APPLE__
++#if defined(__APPLE__) || (defined(__linux__) && !defined(__GLIBC__))
+ # define __SOCKADDR_ARG struct sockaddr *__restrict
+ #endif
+
diff --git a/testing/sblim-sfcc/time-struct.patch b/testing/sblim-sfcc/time-struct.patch
new file mode 100644
index 0000000000..fdfdf50ceb
--- /dev/null
+++ b/testing/sblim-sfcc/time-struct.patch
@@ -0,0 +1,13 @@
+diff --git a/backend/cimxml/indicationlistener.c b/backend/cimxml/indicationlistener.c
+index 0d7d9fe..dd79d8d 100755
+--- a/backend/cimxml/indicationlistener.c
++++ b/backend/cimxml/indicationlistener.c
+@@ -22,7 +22,7 @@
+ #include "nativeCimXml.h"
+ #include "utilft.h"
+ #include "cimXmlParser.h"
+-
++#include <sys/time.h>
+ #include <pthread.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>