aboutsummaryrefslogtreecommitdiffstats
path: root/testing/scstadmin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:46:16 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:46:16 +0100
commit3ccb251e15e3a5692f737149080eecf48c25519a (patch)
treee7d2943d1e040cbaf8984fc0f90364c83802b6a6 /testing/scstadmin
parentac01c4ab99a130bcbcec089506ffe19374cea59d (diff)
downloadaports-3ccb251e15e3a5692f737149080eecf48c25519a.tar.bz2
aports-3ccb251e15e3a5692f737149080eecf48c25519a.tar.xz
testing/scstadmin: remove svn name and update to latest 2.0.0 svn r3161
Diffstat (limited to 'testing/scstadmin')
-rw-r--r--testing/scstadmin/APKBUILD39
-rw-r--r--testing/scstadmin/scst-init-ash-comapt.patch35
2 files changed, 74 insertions, 0 deletions
diff --git a/testing/scstadmin/APKBUILD b/testing/scstadmin/APKBUILD
new file mode 100644
index 0000000000..85350e0675
--- /dev/null
+++ b/testing/scstadmin/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=scstadmin
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="SCST administration tool written in perl"
+url="http://scst.sourceforge.net"
+arch="x86_64"
+license="GPL-2"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+# increase pkgrel when updating svn rev
+_svn="3161"
+source="http://alpine.nethq.org/distfiles/$pkgname-$pkgver-svn-$_svn.tar.gz
+ scst-init-ash-comapt.patch
+ "
+
+_builddir="$srcdir"/$pkgname
+
+prepare() {
+ cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ cd "$_builddir"
+ patch -p1 < "$srcdir"/scst-init-ash-comapt.patch
+}
+
+package() {
+ cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
+ make DESTDIR="$pkgdir" install || return 1
+
+ cd "$_builddir"
+ install -Dm755 scstadmin.sysfs/scstadmin "$pkgdir"/usr/sbin/scstadmin || return 1
+ install -Dm755 init.d/scst.gentoo "$pkgdir"/etc/init.d/scstadmin || return 1
+}
+
+md5sums="8f60857b6545dd60d7d26342aba038f1 scstadmin-2.0.0-svn-3161.tar.gz
+061580b8ec84b5f7da0b1332601f505a scst-init-ash-comapt.patch"
diff --git a/testing/scstadmin/scst-init-ash-comapt.patch b/testing/scstadmin/scst-init-ash-comapt.patch
new file mode 100644
index 0000000000..67cd7adf17
--- /dev/null
+++ b/testing/scstadmin/scst-init-ash-comapt.patch
@@ -0,0 +1,35 @@
+--- scstadmin/init.d/scst.gentoo
++++ scstadmin/init.d/scst.gentoo
+@@ -12,13 +12,11 @@
+ # Note: on most Linux distributions /bin/sh is a soft link to /bin/bash, while
+ # on a default Ubuntu setup /bin/sh is a soft link to /bin/dash !
+
+-opts="${opts} try-restart reload force-reload"
++opts="${opts} try_restart reload force_reload"
+ depend() {
+ use logger
+ }
+
+-PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/local/bin
+-
+ DEFAULTFILE="/etc/conf.d/scst"
+ SCST_CFG=/etc/scst.conf
+ MODPROBE="/sbin/modprobe"
+@@ -121,7 +119,7 @@
+ start
+ }
+
+-try-restart() {
++try_restart() {
+ ## Restart the service if the service is already running.
+ status >/dev/null 2>&1 && restart
+ }
+@@ -140,7 +138,7 @@
+ fi
+ }
+
+-force-reload() {
++force_reload() {
+ ## Cause the configuration to be reloaded if the service supports this,
+ ## otherwise restart the service if it is running.
+ einfo "Reloading SCST configuration"