aboutsummaryrefslogtreecommitdiffstats
path: root/testing/serd
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-17 14:07:24 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-18 09:05:33 +0000
commit1f4a8dca3b557191735612e26bd352dba66dfe2c (patch)
tree8918daa74aeea1a592afd9702407b3bad7b984c8 /testing/serd
parentb6640cc8048871170e653a12e95f631e62f1bc74 (diff)
downloadaports-1f4a8dca3b557191735612e26bd352dba66dfe2c.tar.bz2
aports-1f4a8dca3b557191735612e26bd352dba66dfe2c.tar.xz
testing/serd: new aport
http://drobilla.net/software/lilv lightweight C library for RDF syntax
Diffstat (limited to 'testing/serd')
-rw-r--r--testing/serd/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/serd/APKBUILD b/testing/serd/APKBUILD
new file mode 100644
index 0000000000..07a4d4aaa1
--- /dev/null
+++ b/testing/serd/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=serd
+pkgver=0.30.2
+pkgrel=0
+pkgdesc="lightweight C library for RDF syntax"
+url="http://drobilla.net/software/serd"
+arch="all"
+license="ISC"
+makedepends="python3"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.drobilla.net/serd-$pkgver.tar.bz2"
+options="!check" # No tests
+
+build() {
+ python3 waf configure --prefix=/usr
+ python3 waf build
+}
+
+package() {
+ python3 waf install --destdir="$pkgdir"
+}
+
+sha512sums="b1e18ac883aac2a8146ee0e1de553ac2b512deba5307e5c9fa2733d9011ed0777d67790aa6527e73b3f11c9da0d8c9a98227457bb412897296f4464228cac0f7 serd-0.30.2.tar.bz2"