aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shc
diff options
context:
space:
mode:
authorMrBiTs <mrbits@mbits.com.br>2019-08-08 12:23:50 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-08-08 20:34:54 +0000
commitb6bb6a862e4c4a2fa700f19792eef721e60cd6eb (patch)
tree3a3724c3acf41bc4c590704d4f3234d20f3e1cc1 /testing/shc
parentc8a8b1119a608e15dc2482426fb331a6320afc31 (diff)
downloadaports-b6bb6a862e4c4a2fa700f19792eef721e60cd6eb.tar.bz2
aports-b6bb6a862e4c4a2fa700f19792eef721e60cd6eb.tar.xz
testing/shc: new aport
https://neurobin.org/projects/softwares/unix/shc/ A generic shell script compiler. Closes GH-9960
Diffstat (limited to 'testing/shc')
-rw-r--r--testing/shc/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/shc/APKBUILD b/testing/shc/APKBUILD
new file mode 100644
index 0000000000..2d74dc4a04
--- /dev/null
+++ b/testing/shc/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: MrBiTs <mrbits@mrbits.com.br>
+# Maintainer: MrBiTs <mrbits@mrbits.com.br>
+pkgname="shc"
+pkgver="4.0.3"
+pkgrel=0
+pkgdesc="A generic shell script compiler."
+url="https://neurobin.org/projects/softwares/unix/shc/"
+arch="all"
+license="GPL-3.0-or-later"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mrbitsdcf/shc/archive/$pkgver.tar.gz"
+options="!check" # Test is disabled because developer didn't provide a test function
+
+build() {
+ ./configure
+ make
+}
+
+package() {
+ install -v -m 0755 -d $pkgdir/bin/
+ install -v -m 0755 $builddir/src/shc $pkgdir/bin/
+}
+
+sha512sums="78fbab26c652b3c3a41401e044ae69776fbdf5d28736c55bcf111f4261f863f6d97d81e87ad9288faf9c9a3299c1453dcca9ffd9d9ea04a1ff2b7299257e8cf7 shc-4.0.3.tar.gz"