aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shfmt
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-10-24 21:39:08 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-24 19:43:28 +0000
commit17f424c386842c7d375422415e54ab067645c8b8 (patch)
treef1f40610ddde53eb79f5df165a1217d92ea11a45 /testing/shfmt
parentb8fd6eea0318377e8c66cc432a66b7460c5a22e8 (diff)
downloadaports-17f424c386842c7d375422415e54ab067645c8b8.tar.bz2
aports-17f424c386842c7d375422415e54ab067645c8b8.tar.xz
testing/shfmt: Honor alpine pkver style
While not yet documented, Alpine favors to use plain semver where possible for pkgver. Lets follow suit. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Closes !792
Diffstat (limited to 'testing/shfmt')
-rw-r--r--testing/shfmt/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/shfmt/APKBUILD b/testing/shfmt/APKBUILD
index bfe128eb28..98d547e3c2 100644
--- a/testing/shfmt/APKBUILD
+++ b/testing/shfmt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname="shfmt"
-pkgver="v2.6.4"
+pkgver="2.6.4"
pkgrel=0
pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
url="https://mvdan.cc/sh"
@@ -9,8 +9,8 @@ arch="all"
license="BSD-3-Clause"
options="!check" # No tests available
makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/$pkgver.tar.gz"
-builddir="$srcdir/sh-${pkgver#v*}"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
+builddir="$srcdir/sh-$pkgver"
prepare() {
mkdir -p "$srcdir/go/src/mvdan.cc"
@@ -32,4 +32,4 @@ package() {
"$builddir/shfmt"
}
-sha512sums="e7afd566a35606c6e137654fa1caf349429ba3a27ee804e6763ecdfab779bd189fd5ac853a301bf1d4371dc6115fd89b80474cf051678768f84dd553f7faafe8 shfmt-v2.6.4.tar.gz"
+sha512sums="e7afd566a35606c6e137654fa1caf349429ba3a27ee804e6763ecdfab779bd189fd5ac853a301bf1d4371dc6115fd89b80474cf051678768f84dd553f7faafe8 shfmt-2.6.4.tar.gz"