aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shntool
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-13 03:42:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-13 03:43:24 -0300
commita69cfca0bceb692f4fab2a47de7c19e3ed3a584d (patch)
tree4c87a3c3011433958877e9b5fe06feefe05b5d3d /testing/shntool
parent8ec602e42f54d2b3b79fff6996c26f1aeaa77565 (diff)
downloadaports-a69cfca0bceb692f4fab2a47de7c19e3ed3a584d.tar.bz2
aports-a69cfca0bceb692f4fab2a47de7c19e3ed3a584d.tar.xz
testing/shntool: fix build fix license fix url fix source
Diffstat (limited to 'testing/shntool')
-rw-r--r--testing/shntool/APKBUILD20
-rw-r--r--testing/shntool/shntool-3.0.10-large-size.patch23
-rw-r--r--testing/shntool/shntool-3.0.10-large-times.patch40
3 files changed, 73 insertions, 10 deletions
diff --git a/testing/shntool/APKBUILD b/testing/shntool/APKBUILD
index 531017f66b..03edb55cb4 100644
--- a/testing/shntool/APKBUILD
+++ b/testing/shntool/APKBUILD
@@ -2,19 +2,20 @@
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=shntool
pkgver=3.0.10
-pkgrel=1
+pkgrel=2
pkgdesc="A multi-purpose WAVE data processing and reporting utility"
-url="http://www.etree.org/shnutils/shntool/"
+url="http://shnutils.freeshell.org/shntool/"
arch="all"
-license="GPL"
+license="GPL-2.0-or-later"
makedepends="sox"
subpackages="$pkgname-doc"
-source="http://www.etree.org/shnutils/shntool/dist/src/shntool-$pkgver.tar.gz"
+source="http://shnutils.freeshell.org/shntool/dist/src/${pkgname}-${pkgver}.tar.gz
+ shntool-3.0.10-large-size.patch
+ shntool-3.0.10-large-times.patch
+ "
-builddir="$srcdir"/shntool-$pkgver
build() {
- cd "$builddir"
update_config_sub
./configure \
--build=$CBUILD \
@@ -28,7 +29,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -58,6 +58,6 @@ check() {
rm -r test
}
-md5sums="5d41f8f42c3c15e3145a7a43539c3eae shntool-3.0.10.tar.gz"
-sha256sums="74302eac477ca08fb2b42b9f154cc870593aec8beab308676e4373a5e4ca2102 shntool-3.0.10.tar.gz"
-sha512sums="2150d7123860abb54a56a1615bda991ed3713d73c338723f28b7d01a63c49a47809be16dc57b5b4edeee1567b003f9a4b54945c1cd08440f9503d22b91eaa06d shntool-3.0.10.tar.gz"
+sha512sums="2150d7123860abb54a56a1615bda991ed3713d73c338723f28b7d01a63c49a47809be16dc57b5b4edeee1567b003f9a4b54945c1cd08440f9503d22b91eaa06d shntool-3.0.10.tar.gz
+fc44bca63d79b279db6d275caaacdb73cbebd6b902276a9052f005146fa125f4674e3cf559d46405637a337192f4a38f9bec4836af46e7ae52e4f220352c1ba7 shntool-3.0.10-large-size.patch
+9780f22d93e20dd01d18067978bdf6cbb0b460bb80f41c4f4752b3322c3d70182b3acf35b789e30fc36ca52af6127e24c00599fb49b916f01448613721a94ebe shntool-3.0.10-large-times.patch"
diff --git a/testing/shntool/shntool-3.0.10-large-size.patch b/testing/shntool/shntool-3.0.10-large-size.patch
new file mode 100644
index 0000000000..908d297b05
--- /dev/null
+++ b/testing/shntool/shntool-3.0.10-large-size.patch
@@ -0,0 +1,23 @@
+diff -aur shntool-3.0.10-clean/src/core_fileio.c shntool-3.0.10-size/src/core_fileio.c
+--- shntool-3.0.10-clean/src/core_fileio.c 2009-03-11 17:18:01.000000000 +0000
++++ shntool-3.0.10-size/src/core_fileio.c 2012-08-11 17:20:14.000000000 +0100
+@@ -110,10 +110,16 @@
+ buf[4] = 0;
+
+ if (be_val)
+- *be_val = (buf[0] << 24) | (buf[1] << 16) | (buf[2] << 8) | buf[3];
++ *be_val = (((unsigned long)buf[0]) << 24)
++ | (((unsigned long)buf[1]) << 16)
++ | (((unsigned long)buf[2]) << 8)
++ | ((unsigned long)buf[3]);
+
+ if (le_val)
+- *le_val = (buf[3] << 24) | (buf[2] << 16) | (buf[1] << 8) | buf[0];
++ *le_val = (((unsigned long)buf[3]) << 24)
++ | (((unsigned long)buf[2]) << 16)
++ | (((unsigned long)buf[1]) << 8)
++ | ((unsigned long)buf[0]);
+
+ if (tag_val)
+ tagcpy(tag_val,buf);
+
diff --git a/testing/shntool/shntool-3.0.10-large-times.patch b/testing/shntool/shntool-3.0.10-large-times.patch
new file mode 100644
index 0000000000..7c7263e936
--- /dev/null
+++ b/testing/shntool/shntool-3.0.10-large-times.patch
@@ -0,0 +1,40 @@
+diff -aur shntool-3.0.10-clean/src/core_mode.c shntool-3.0.10/src/core_mode.c
+--- shntool-3.0.10-clean/src/core_mode.c 2009-03-30 06:55:33.000000000 +0100
++++ shntool-3.0.10/src/core_mode.c 2012-08-11 16:37:58.000000000 +0100
+@@ -310,8 +310,8 @@
+ if (sec >= 60)
+ st_error("invalid value for seconds: [%d]",sec);
+
+- bytes = (wlong)(min * info->rate * 60) +
+- (wlong)(sec * info->rate);
++ bytes = (((wlong)min) * info->rate * 60) +
++ (((wlong)sec) * info->rate);
+
+ return bytes;
+ }
+@@ -358,9 +358,9 @@
+ if (frames >= 75)
+ st_error("invalid value for frames: [%d]",frames);
+
+- bytes = (wlong)(min * CD_RATE * 60) +
+- (wlong)(sec * CD_RATE) +
+- (wlong)(frames * CD_BLOCK_SIZE);
++ bytes = (((wlong)min) * CD_RATE * 60) +
++ (((wlong)sec) * CD_RATE) +
++ (((wlong)frames) * CD_BLOCK_SIZE);
+
+ return bytes;
+ }
+@@ -403,8 +403,8 @@
+
+ nearest_byte = (int)((((double)ms * (double)info->rate) / 1000.0) + 0.5);
+
+- bytes = (wlong)(min * info->rate * 60) +
+- (wlong)(sec * info->rate);
++ bytes = (((wlong)min) * info->rate * 60) +
++ (((wlong)sec) * info->rate);
+
+ if (PROB_NOT_CD(info)) {
+ bytes += nearest_byte;
+
+