aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shorewall/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-27 14:59:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-27 14:59:51 +0000
commit8fdc7a598b7e305d11e758922a43916ee3e7c145 (patch)
tree9a43b66606788bd370417984662f9aae70c248c8 /testing/shorewall/APKBUILD
parente83a84a337d20424457580ef1bda5b0fec2bd836 (diff)
downloadaports-8fdc7a598b7e305d11e758922a43916ee3e7c145.tar.bz2
aports-8fdc7a598b7e305d11e758922a43916ee3e7c145.tar.xz
testing/shorewall: upgrade to 4.5.18
Diffstat (limited to 'testing/shorewall/APKBUILD')
-rw-r--r--testing/shorewall/APKBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/testing/shorewall/APKBUILD b/testing/shorewall/APKBUILD
index 4a7ffa1de0..64f77ecdbd 100644
--- a/testing/shorewall/APKBUILD
+++ b/testing/shorewall/APKBUILD
@@ -1,20 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.4.21
-pkgrel=1
-pkgdesc="Shoreline Firewall is an iptables-based firewall for Linux."
+pkgver=4.5.18
+pkgrel=0
+pkgdesc="Core libraries for Shorewall"
url="http://www.shorewall.net/"
arch="noarch"
license="GPL-2"
-depends="iptables iproute2 perl"
-replaces="shorewall-common shorewall-perl"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils"
+replaces=""
subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.4/shorewall-$pkgver/shorewall-$pkgver.tar.bz2
+source="http://www1.shorewall.net/pub/shorewall/${pkgver%.*}/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
shorewall.initd
- shorewall-no-install-T.patch
"
-_builddir="src/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
local i
cd "$_builddir"
@@ -27,18 +28,19 @@ prepare() {
build() {
cd "$_builddir"
-
- PREFIX="${pkgdir}" ./install.sh || return 1
- install -Dm755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
}
-doc() {
- default_doc
- mkdir -p "$subpkgdir/usr/share/shorewall"
- mv "$pkgdir/usr/share/shorewall/configfiles" \
- "$subpkgdir/usr/share/shorewall/"
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall
+ install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
-md5sums="aac1823063489563330bf5dc57a26487 shorewall-4.4.21.tar.bz2
-3dcf9a43bf7ce03f1d839a97ccf2240d shorewall.initd
-546ca14bae43f5046f193efc884c768b shorewall-no-install-T.patch"
+md5sums="c32a1a14349e9c2c6df32880c08d8d42 shorewall-4.5.18.tar.bz2
+a59c0ec3f299f6a383d33aacbdc83e44 shorewall.initd"
+sha256sums="81bbcb2cc24d0b54769fb153cb472d78e6eed9cdc9f005f1dd70ef2ae9efe131 shorewall-4.5.18.tar.bz2
+ee8cff251a24cc5f9b31e835682f6fc7d9f01625e93c2f9d8c82c859dad09e8e shorewall.initd"
+sha512sums="69857ba9181989a0d0b8ce691e637b313b59d4f5643784e62a801f8d74add0605452011e19e5344aaca97a329fe66980627181e69d9c0fc0625ff23afb192f78 shorewall-4.5.18.tar.bz2
+365819451ee3a412c321eea4d3011c548295f00f9dd2cbb996c84a61be77eae859d568077677f1acad64af2a642028e2ef577a3757239703153b3293232afade shorewall.initd"