aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shorewall/APKBUILD
diff options
context:
space:
mode:
authorJohn Keith Hohm <john@hohm.net>2011-07-19 00:33:28 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-20 07:14:34 +0000
commitff98019fb73e2dce4209fab94d46f4036a6189d7 (patch)
tree13014fbae93145ac54daef524e94d465731c7dfb /testing/shorewall/APKBUILD
parent180fccae2cc4235fa32be9f0df2ede1b896ea25d (diff)
downloadaports-ff98019fb73e2dce4209fab94d46f4036a6189d7.tar.bz2
aports-ff98019fb73e2dce4209fab94d46f4036a6189d7.tar.xz
testing/shorewall: upgrade to Perl-only shorewall-4.4.21
Diffstat (limited to 'testing/shorewall/APKBUILD')
-rw-r--r--testing/shorewall/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/shorewall/APKBUILD b/testing/shorewall/APKBUILD
new file mode 100644
index 0000000000..05e05ca91c
--- /dev/null
+++ b/testing/shorewall/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shorewall
+pkgver=4.4.21
+pkgrel=0
+pkgdesc="Shoreline Firewall is an iptables-based firewall for Linux."
+url="http://www.shorewall.net/"
+arch="noarch"
+license="GPL-2"
+depends="iptables iproute2 perl"
+replaces="shorewall-common shorewall-perl"
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/4.4/shorewall-$pkgver/shorewall-$pkgver.tar.bz2
+ shorewall.initd
+ shorewall-no-install-T.patch
+ "
+
+_builddir="src/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ PREFIX="${pkgdir}" ./install.sh || return 1
+ install -Dm755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
+}
+
+doc() {
+ default_doc
+ mkdir -p "$subpkgdir/usr/share/shorewall"
+ mv "$pkgdir/usr/share/shorewall/configfiles" \
+ "$subpkgdir/usr/share/shorewall/"
+}
+
+md5sums="aac1823063489563330bf5dc57a26487 shorewall-4.4.21.tar.bz2
+71fb6da1f50f5c6e9dd35b60b3629531 shorewall.initd
+546ca14bae43f5046f193efc884c768b shorewall-no-install-T.patch"