aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sigrok-firmware-fx2lafw-bin
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-06-10 21:09:12 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-06-10 22:42:58 +0200
commitc222004970c9e9a77ff25f588c5eb090029712c8 (patch)
treea0b3c2234a0a9b0388f5154e9f8d9df36d9b92c8 /testing/sigrok-firmware-fx2lafw-bin
parent6d0ec08836be5b30b8585d9410d35dcef09ea762 (diff)
downloadaports-c222004970c9e9a77ff25f588c5eb090029712c8.tar.bz2
aports-c222004970c9e9a77ff25f588c5eb090029712c8.tar.xz
testing/sigrok-firmware-fx2lafw-bin: New aport
Open source firmware for logic analyzers based on Cypress FX2 chips https://sigrok.org/wiki/Libsigrok
Diffstat (limited to 'testing/sigrok-firmware-fx2lafw-bin')
-rw-r--r--testing/sigrok-firmware-fx2lafw-bin/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/sigrok-firmware-fx2lafw-bin/APKBUILD b/testing/sigrok-firmware-fx2lafw-bin/APKBUILD
new file mode 100644
index 0000000000..35c5c5de7d
--- /dev/null
+++ b/testing/sigrok-firmware-fx2lafw-bin/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+
+pkgname="sigrok-firmware-fx2lafw-bin"
+replaces="${pkgname%-bin}"
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="Open source firmware for logic analyzers based on Cypress FX2 chips"
+url="https://sigrok.org/wiki/Libsigrok"
+arch="noarch"
+license="GPL-2.0-or-later"
+# Using prebuild firmware, as required toolchain is not (yet) available on
+# Alpine Linux
+source="https://sigrok.org/download/binary/${pkgname%-bin}/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+# No checks possible, as firmware runs on the logic analyzer
+options="!check"
+
+package() {
+ mkdir -p "$pkgdir/usr/share/sigrok-firmware"
+ find . -type f -name '*.fw' \
+ -exec cp {} "$pkgdir/usr/share/sigrok-firmware" \;
+}
+
+sha512sums="0dd4eb5327fbf5a8ee413b5ad460e2febe7da6aba13cfe4c7467966e4d4a0033b796ce7634647c0bbfa335034180272e7f8167b7a8181fb73ed3839891a44e46 sigrok-firmware-fx2lafw-bin-0.1.6.tar.gz"