aboutsummaryrefslogtreecommitdiffstats
path: root/testing/slop/APKBUILD
diff options
context:
space:
mode:
authorSamuel Hunter <samuelhunter1024@gmail.com>2019-12-15 22:14:22 -0800
committerLeo <thinkabit.ukim@gmail.com>2019-12-16 08:06:18 +0100
commita7497c1042e0257ca249a879c12e3ed401084ded (patch)
tree16ef763a8b3a6a73b477861ddd7187d2a791a3df /testing/slop/APKBUILD
parent5e426909847837ccdc541fa3277983b5547b976a (diff)
downloadaports-a7497c1042e0257ca249a879c12e3ed401084ded.tar.bz2
aports-a7497c1042e0257ca249a879c12e3ed401084ded.tar.xz
testing/slop: new aport
https://github.com/naelstrof/slop Application that queries for a selection from the user and prints the region to stdout Signed-off-by: Samuel Hunter <samuelhunter1024@gmail.com>
Diffstat (limited to 'testing/slop/APKBUILD')
-rw-r--r--testing/slop/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/slop/APKBUILD b/testing/slop/APKBUILD
new file mode 100644
index 0000000000..46a40a6ed7
--- /dev/null
+++ b/testing/slop/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Samuel Hunter <samuelhunter1024@gmail.com>
+# Maintainer: Samuel Hunter <samuelhunter1024@gmail.com>
+pkgname="slop"
+pkgver="7.4"
+pkgrel=0
+pkgdesc="Application that queries for a selection from the user and prints the region to stdout"
+url="https://github.com/naelstrof/slop"
+arch="all"
+license="MIT"
+makedepends="cmake icu-dev mesa-dev glew-dev glu-dev libice-dev libsm-dev
+ libx11-dev libxext-dev libxrender-dev glm-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/naelstrof/slop/archive/v$pkgver.tar.gz"
+options="!check" # No tests
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="13d09c2c9f05760ee0a273edb6d40da8a87989d3f071a8c868a0c7e535ba89b9eb934c79d56212cd689687f86e3683cef1b749ef7b37be3805ea8eb05c796e58 slop-7.4.tar.gz"