aboutsummaryrefslogtreecommitdiffstats
path: root/testing/slop
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 02:11:40 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-23 16:00:18 +0000
commit91ffc449712605115d3aedbdaa13830f1b47f024 (patch)
tree0156e90c130de39e3c8b1846187c612510943a2c /testing/slop
parent3bdb5e8a10ac1b3c7242fb3da7794ad705a0b759 (diff)
downloadaports-91ffc449712605115d3aedbdaa13830f1b47f024.tar.bz2
aports-91ffc449712605115d3aedbdaa13830f1b47f024.tar.xz
testing/slop: new aport
Diffstat (limited to 'testing/slop')
-rw-r--r--testing/slop/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/slop/APKBUILD b/testing/slop/APKBUILD
new file mode 100644
index 0000000000..30728f17c3
--- /dev/null
+++ b/testing/slop/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=slop
+pkgver=7.4
+pkgrel=0
+pkgdesc="Utility to query for a selection and print the region to stdout"
+url="https://github.com/naelstrof/slop"
+options="!check" # Does not provide a test suite
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="
+ cmake
+ glew-dev
+ glm-dev
+ icu-dev
+ libxrender-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/naelstrof/slop/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="13d09c2c9f05760ee0a273edb6d40da8a87989d3f071a8c868a0c7e535ba89b9eb934c79d56212cd689687f86e3683cef1b749ef7b37be3805ea8eb05c796e58 slop-7.4.tar.gz"