aboutsummaryrefslogtreecommitdiffstats
path: root/testing/smartmontools/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-11 14:52:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-11 14:52:25 +0000
commit468d3e89253a2a0af7e69557fe0f60bb1cde7377 (patch)
treee8ddc0e6aff2d092c97c41cfc5d57768435ef4d9 /testing/smartmontools/APKBUILD
parent2283129aea3418baea59a73e7251651aa2e85656 (diff)
downloadaports-468d3e89253a2a0af7e69557fe0f60bb1cde7377.tar.bz2
aports-468d3e89253a2a0af7e69557fe0f60bb1cde7377.tar.xz
testing/smartmontools: new aport
Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives. http://smartmontools.sourceforge.net
Diffstat (limited to 'testing/smartmontools/APKBUILD')
-rw-r--r--testing/smartmontools/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/smartmontools/APKBUILD b/testing/smartmontools/APKBUILD
new file mode 100644
index 0000000000..8ba05087af
--- /dev/null
+++ b/testing/smartmontools/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=smartmontools
+pkgver=5.38
+pkgrel=0
+pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
+url="http://smartmontools.sourceforge.net"
+license="GPL"
+depends=
+makedepends=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ smartd.initd
+ smartd.confd
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir"/ install
+ rm -r "$pkgdir"/etc/rc.d
+ install -Dm755 ../smartd.initd "$pkgdir"/etc/init.d/smartd
+ install -Dm644 ../smartd.confd "$pkgdir"/etc/conf.d/smartd
+}
+md5sums="a282846532ecbd6b4a28072373b3a70b smartmontools-5.38.tar.gz
+64e6fc908146b885aa3f88796edf72f3 smartd.initd
+371cdb7cc9dc924b6d12224d66b193c6 smartd.confd"