aboutsummaryrefslogtreecommitdiffstats
path: root/testing/snapper/remove-systemd.patch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-02-24 11:33:56 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 18:00:21 -0300
commit49fbe56b0a52ef1f3117688f45096b53433ca235 (patch)
tree11e89f704516ec4b7909a2305350e1486f391c9d /testing/snapper/remove-systemd.patch
parent48d608564cc17601a290e7a27dc3e85bacb08eae (diff)
downloadaports-49fbe56b0a52ef1f3117688f45096b53433ca235.tar.bz2
aports-49fbe56b0a52ef1f3117688f45096b53433ca235.tar.xz
testing/snapper: upgrade to 0.8.9
Diffstat (limited to 'testing/snapper/remove-systemd.patch')
-rw-r--r--testing/snapper/remove-systemd.patch33
1 files changed, 23 insertions, 10 deletions
diff --git a/testing/snapper/remove-systemd.patch b/testing/snapper/remove-systemd.patch
index 8f84cba64f..9751bd5f91 100644
--- a/testing/snapper/remove-systemd.patch
+++ b/testing/snapper/remove-systemd.patch
@@ -1,16 +1,29 @@
---- a/data/Makefile.am.orig
+--- a/configure.ac
+@@ -123,6 +119,10 @@ AC_ARG_ENABLE([zypp], AC_HELP_STRING([--disable-zypp],[Disable zypp plugin suppo
+ [with_zypp=$enableval],[with_zypp=yes])
+ AM_CONDITIONAL(HAVE_ZYPP, [test "x$with_zypp" = "xyes"])
+
++AC_ARG_ENABLE([systemd], AC_HELP_STRING([--disable-systemd],[Disable systemd support]),
++ [enable_systemd=$enableval],[enable_systemd=yes])
++AM_CONDITIONAL(ENABLE_SYSTEMD, [test "x$enable_systemd" = "xyes"])
++
+ AC_CHECK_LIB(btrfs, btrfs_read_and_process_send_stream)
+ AC_CHECK_HEADERS([btrfs/version.h])
+
+--- a/data/Makefile.am
+++ b/data/Makefile.am
-@@ -21,13 +21,6 @@
+@@ -21,12 +21,14 @@ install-data-local:
install -D -m 644 org.opensuse.Snapper.conf $(DESTDIR)/etc/dbus-1/system.d/org.opensuse.Snapper.conf
install -D -m 644 org.opensuse.Snapper.service $(DESTDIR)/usr/share/dbus-1/system-services/org.opensuse.Snapper.service
-- install -D -m 644 timeline.service $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.service
-- install -D -m 644 timeline.timer $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.timer
-- install -D -m 644 cleanup.service $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.service
-- install -D -m 644 cleanup.timer $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.timer
-- install -D -m 644 boot.service $(DESTDIR)/usr/lib/systemd/system/snapper-boot.service
-- install -D -m 644 boot.timer $(DESTDIR)/usr/lib/systemd/system/snapper-boot.timer
--
++if ENABLE_SYSTEMD
+ install -D -m 644 timeline.service $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.service
+ install -D -m 644 timeline.timer $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.timer
+ install -D -m 644 cleanup.service $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.service
+ install -D -m 644 cleanup.timer $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.timer
+ install -D -m 644 boot.service $(DESTDIR)/usr/lib/systemd/system/snapper-boot.service
+ install -D -m 644 boot.timer $(DESTDIR)/usr/lib/systemd/system/snapper-boot.timer
++endif
+
if HAVE_ZYPP
install -D -m 644 zypp-plugin.conf $(DESTDIR)/etc/snapper/zypp-plugin.conf
- endif