aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spampd
diff options
context:
space:
mode:
authorChloe Kudryavtsev <toast@toastin.space>2018-11-03 21:22:59 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-09 14:06:06 +0000
commita5a124a7baec9eddae08acd6f72ce8fc71f68a21 (patch)
tree490673e8c93845d43973f06e6f17ccf6815ee250 /testing/spampd
parent95911a5ea48744c72dd4a3ec0d3b0ca5568fddd9 (diff)
downloadaports-a5a124a7baec9eddae08acd6f72ce8fc71f68a21.tar.bz2
aports-a5a124a7baec9eddae08acd6f72ce8fc71f68a21.tar.xz
testing/spampd: new aport
https://www.worlddesign.com/index.cfm/page/software/open-source/spampd.htm An SMTP / LMTP proxy that uses spamassassin to mark spam. Similar to amavisd-new, but lets spamassassin modify headers directly, and significantly simpler to use/configure.
Diffstat (limited to 'testing/spampd')
-rw-r--r--testing/spampd/APKBUILD41
-rw-r--r--testing/spampd/spampd.confd13
-rw-r--r--testing/spampd/spampd.initd16
-rw-r--r--testing/spampd/spampd.pre-install6
4 files changed, 76 insertions, 0 deletions
diff --git a/testing/spampd/APKBUILD b/testing/spampd/APKBUILD
new file mode 100644
index 0000000000..026dc772bf
--- /dev/null
+++ b/testing/spampd/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
+pkgname=spampd
+pkgver=2.51
+pkgrel=0
+pkgdesc="An L/SMTP proxy that marks spam using spamassassin."
+url="http://www.worlddesign.com/index.cfm/page/software/open-source/spampd.htm"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="perl-net-server perl-mail-spamassassin"
+makedepends=""
+install="spampd.pre-install"
+subpackages="$pkgname-openrc" # spampd.8 seems to have been removed at some point
+source="
+ spampd.confd
+ spampd.initd
+ $pkgname-$pkgver.tar.gz::https://github.com/mpaperno/$pkgname/archive/$pkgver.tar.gz
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+pkgusers="spampd"
+pkggroups="spampd"
+
+build() {
+ return 0
+}
+
+check() {
+ cd "$builddir"
+ ./spampd.pl -? # even --version is missing, but if there's a missing module, this fails
+}
+
+package() {
+ install -m755 -D "$builddir/$pkgname.pl" "$pkgdir/usr/bin/$pkgname"
+}
+
+openrc() {
+ install -m755 -D "$srcdir/$pkgname.initd" "$subpkgdir/etc/init.d/$pkgname"
+ install -m644 -D "$srcdir/$pkgname.confd" "$subpkgdir/etc/conf.d/$pkgname"
+}
+sha512sums="216ab774ac2cc8b54fb8f2155738fd41264b261efd5a7ab95d9910aad5b9699065f42211dbe8021383f0172bfb50cfc9087ea8dc1e53a2223dabd7faf490769c spampd.confd
+4adad6b44509abedcfb5726d09a63b66048468e5ee7942d0e586630a84fb93931f315ed9410894af2cc4e5bff04cd38600ea91cc0b18c3cedd67efe2af6e0e14 spampd.initd
+a766815e2c563f4ba520a423adee34791cb901d301872cfcdc4047ff4668f74e0ecf488e6ad964dd45bd530686440f249b7656ce0ae95cca7fdae42b02badd32 spampd-2.51.tar.gz"
diff --git a/testing/spampd/spampd.confd b/testing/spampd/spampd.confd
new file mode 100644
index 0000000000..3a9f88d8f6
--- /dev/null
+++ b/testing/spampd/spampd.confd
@@ -0,0 +1,13 @@
+user=spampd
+group=spampd
+
+#host=127.0.0.1
+#port=10025
+#sock=/run/spampd.sock # overrides host and port
+#smod=660
+
+#rhost=127.0.0.1
+rport=10026
+#rsock=/run/dovecot/lmtp # user:group must have r/w permissions
+
+args="--dose" # add -d here if desired
diff --git a/testing/spampd/spampd.initd b/testing/spampd/spampd.initd
new file mode 100644
index 0000000000..139830f158
--- /dev/null
+++ b/testing/spampd/spampd.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+command="/usr/bin/spampd"
+pidfile="/run/${RC_SVCNAME}.pid"
+command_args="-p=$pidfile
+ ${user:+-u=$user} ${group:+-g=$group}
+ ${host:+--host=$host} ${port:+--port=$port}
+ ${sock:+--socket=$sock} ${smod:+--socket-perms=$smod}
+ ${rhost:+--relayhost=$rhost} ${rport:+--relayport=$rport}
+ ${rsock:+--relaysocket=$rsock}
+ $args"
+
+# no reload because HUP does not reload spamassassin configuration
+
+depend() {
+ before mta
+}
diff --git a/testing/spampd/spampd.pre-install b/testing/spampd/spampd.pre-install
new file mode 100644
index 0000000000..40d8a8c82c
--- /dev/null
+++ b/testing/spampd/spampd.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S spampd 2>/dev/null
+adduser -S -D -H -s /sbin/nologin -G spampd -g spampd spampd 2>/dev/null
+
+exit 0