aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spectrwm
diff options
context:
space:
mode:
authorOlivier Mauras <olivier@mauras.ch>2015-03-17 02:17:51 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-17 12:57:44 +0000
commitf9a9d4615c18c606e292546b9766ffbe988a01e6 (patch)
treeae222d0c749ea5a5875d041fcba880c7f962def1 /testing/spectrwm
parent959ff2449eff117a8d3027d0feedcc2a49fe43b8 (diff)
downloadaports-f9a9d4615c18c606e292546b9766ffbe988a01e6.tar.bz2
aports-f9a9d4615c18c606e292546b9766ffbe988a01e6.tar.xz
testing/spectrwm: new aport
https://opensource.conformal.com/wiki/spectrwm A small dynamic tiling window manager for X11
Diffstat (limited to 'testing/spectrwm')
-rw-r--r--testing/spectrwm/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/spectrwm/APKBUILD b/testing/spectrwm/APKBUILD
new file mode 100644
index 0000000000..e0e1769c7e
--- /dev/null
+++ b/testing/spectrwm/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Maintainer:
+pkgname=spectrwm
+pkgver=2.6.2
+pkgrel=0
+pkgdesc="A small dynamic tiling window manager for X11"
+url="https://opensource.conformal.com/wiki/spectrwm"
+arch="all"
+license="ISC"
+depends=""
+depends_dev="xorg-server-dev libxrandr-dev libxcursor-dev libxft-dev xcb-util-dev xcb-util-wm-dev xcb-util-keysyms-dev libxt-dev"
+makedepends="$depends_dev bsd-compat-headers"
+install=""
+subpackages="$pkgname-doc"
+source="https://opensource.conformal.com/snapshots/$pkgname/$pkgname-$pkgver.tgz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir/linux"
+ sed -i 's#^PREFIX.*#PREFIX ?= /usr#' Makefile
+}
+
+build() {
+ cd "$_builddir/linux"
+ make
+}
+
+package() {
+ cd "$_builddir/linux"
+ make DESTDIR="$pkgdir" install || return 1
+ # Copy sample scripts and conf
+ mkdir "$pkgdir"/usr/share/$pkgname
+ cp ../*.sh "$pkgdir"/usr/share/$pkgname
+ cp ../*.conf "$pkgdir"/usr/share/$pkgname
+}
+
+md5sums="eba7cba0c85706435657f744bf9086bc spectrwm-2.6.2.tgz"
+sha256sums="eb9b33ee05b0625d59607f886d9ba7f0723bd863b503d66bdb592f5461c59459 spectrwm-2.6.2.tgz"
+sha512sums="f1962df679ca07ca7d8c68a2d0b88331eda5c7cd35ecf1a5a63687984c1c67ef48fffb4e29d273fb1ccef9c9bb77a5ab12a09ef27b1d97abdc87dc20f38717f5 spectrwm-2.6.2.tgz"