aboutsummaryrefslogtreecommitdiffstats
path: root/testing/speedtest
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-11-16 11:12:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-11-16 11:12:48 +0000
commitf48646803e19fc951369fcd4cdd2bbbbcd12a30c (patch)
treeac6727604c83d4b37ad8b4ae1d06b48e06d4ded7 /testing/speedtest
parente649e47a87be19b1c58c71931ce7d2ead250dc52 (diff)
downloadaports-f48646803e19fc951369fcd4cdd2bbbbcd12a30c.tar.bz2
aports-f48646803e19fc951369fcd4cdd2bbbbcd12a30c.tar.xz
testing/speedtest: new aport
Diffstat (limited to 'testing/speedtest')
-rw-r--r--testing/speedtest/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/speedtest/APKBUILD b/testing/speedtest/APKBUILD
new file mode 100644
index 0000000000..b234628044
--- /dev/null
+++ b/testing/speedtest/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=speedtest
+pkgver=4.6.2
+pkgrel=0
+pkgdesc="Self-hosted HTML5 Speedtest."
+url="http://speedtest.fdossena.com"
+arch="noarch"
+options="!check"
+license="LGPL"
+source="$pkgname-$pkgver.tar.gz::https://github.com/adolfintel/speedtest/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/webapps/$pkgname
+ cp -r "$builddir"/* "$pkgdir"/usr/share/webapps/$pkgname
+}
+
+sha512sums="24fef6d9e9b9428e145ac564a66effdfbd84630a9183cb5e1c568ec8bd18d3577920c7ba631103a2c3f27f35cd4e2637b0c2598d61b1afe40642f58a447b5bd4 speedtest-4.6.2.tar.gz"