aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ssh-cert-authority
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-18 22:09:21 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-18 22:09:36 +0000
commit3d087765f687f814be88fb8c1eb755abbe933e7d (patch)
tree2725515a0517165d5558ec164e04ff85a0ffff9e /testing/ssh-cert-authority
parent9379df6ef4c76e518ee954f5f9fcbb180409619d (diff)
downloadaports-3d087765f687f814be88fb8c1eb755abbe933e7d.tar.bz2
aports-3d087765f687f814be88fb8c1eb755abbe933e7d.tar.xz
testing/ssh-cert-authority: new aport
Diffstat (limited to 'testing/ssh-cert-authority')
-rw-r--r--testing/ssh-cert-authority/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/ssh-cert-authority/APKBUILD b/testing/ssh-cert-authority/APKBUILD
new file mode 100644
index 0000000000..274cab66e3
--- /dev/null
+++ b/testing/ssh-cert-authority/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer:
+pkgname=ssh-cert-authority
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="An implementation of an SSH certificate authority"
+url="https://github.com/cloudtools/ssh-cert-authority"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cloudtools/ssh-cert-authority/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ local pkg=github.com/cloudtools/ssh-cert-authority
+ GO111MODULE=on HOME="$srcdir" go build \
+ -ldflags "-X $pkg/version.Tag=$pkgver \
+ -X $pkg/version.BuildVersion=$pkgver" \
+ -o bin/$pkgname
+}
+
+check() {
+ cd "$builddir"
+ go test ./...
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+cleanup_srcdir() {
+ if [ -d "$srcdir" ]; then
+ find "$srcdir" -print0 | xargs -0 chmod +w
+ fi
+ default_cleanup_srcdir
+}
+
+sha512sums="028f0484299ef2b598a168467e576cb3ff326e6cb9acc8393b4df68a29f0fb7a017332e3da8d4afffa9f86518f0d5bac588c11abf1f94ae1391066bc65ca9aa8 ssh-cert-authority-1.7.1.tar.gz"