aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ssh-tools
diff options
context:
space:
mode:
authorSven Wick <sven.wick@gmx.de>2018-12-26 02:58:53 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 19:01:53 -0300
commita51e97677f9b03da0c75bbea1fc3d0267fc7c55c (patch)
tree263d4a15bac919b6d79aa7225ef1bf0ef6b97d3d /testing/ssh-tools
parent390f9be9d840f55260068e0c35de5688daa76d1a (diff)
downloadaports-a51e97677f9b03da0c75bbea1fc3d0267fc7c55c.tar.bz2
aports-a51e97677f9b03da0c75bbea1fc3d0267fc7c55c.tar.xz
testing/ssh-tools: new aport
https://github.com/vaporup/ssh-tools/ collection of various tools using ssh
Diffstat (limited to 'testing/ssh-tools')
-rw-r--r--testing/ssh-tools/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/testing/ssh-tools/APKBUILD b/testing/ssh-tools/APKBUILD
new file mode 100644
index 0000000000..e9ea1e9102
--- /dev/null
+++ b/testing/ssh-tools/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Sven Wick <sven.wick@gmx.de>
+# Maintainer: Sven Wick <sven.wick@gmx.de>
+
+pkgname="ssh-tools"
+pkgver="1.5"
+pkgrel=0
+pkgdesc="collection of various tools using ssh"
+arch="noarch"
+url="https://github.com/vaporup/ssh-tools/"
+license="GPL-3.0-or-later"
+depends="bash colordiff cmd:ssh cmd:ssh-keygen cmd:ssh-keyscan cmd:tput"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/vaporup/${pkgname}/archive/v${pkgver}.tar.gz"
+options="!check" # does not have a testsuite
+
+package() {
+ install -Dt "${pkgdir}/usr/bin" ssh-*
+}
+
+sha512sums="70fd63661d33c79037a9bd62457a583452f5763a32467d0d1058638afe2a9e5e033917ca0d1e627a4db69bc7451097a36a57a763d5bc436f224ecf27eb759e19 ssh-tools-1.5.tar.gz"