aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sshign
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-11-02 16:20:38 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-11-02 19:46:35 -0300
commit6eff1783cdf5555105b0a67ef3a10eae64670a04 (patch)
tree7d5a87e4fa94a4f1a93007942de91065bb42a0fe /testing/sshign
parentef5806667fb2c1cf74c6260cf4703c228025be15 (diff)
downloadaports-6eff1783cdf5555105b0a67ef3a10eae64670a04.tar.bz2
aports-6eff1783cdf5555105b0a67ef3a10eae64670a04.tar.xz
testing/sshign: new aport
Diffstat (limited to 'testing/sshign')
-rw-r--r--testing/sshign/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/sshign/APKBUILD b/testing/sshign/APKBUILD
new file mode 100644
index 0000000000..5116a44a6c
--- /dev/null
+++ b/testing/sshign/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=sshign
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Small program to sign & verify files with your SSH key"
+url="https://git.sr.ht/~minus/sshign"
+arch="all"
+license="MIT"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~minus/sshign/archive/$pkgver.tar.gz"
+options="!check" # No upstream tests
+
+build() {
+ make PREFIX=/usr
+}
+
+package() {
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+sha512sums="284b56f7420fbf8a0a96fcb8456b28d9ed759320d1b3bc8c06f96211f535817fcc54a7a925807fe845b28e5294a76305fb15f566659eef1e8a2f70e51bb6fe2f sshign-0.1.0.tar.gz"