aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sshuttle
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-01-15 10:40:20 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2020-01-15 10:41:16 +0100
commit02847152f7ad083e86d665a94739e1d0c539034c (patch)
tree9f107c321cd59fb685fc6edb75aa57f571b2c78b /testing/sshuttle
parent7f3138a546eaeca0cff20fba985eee9d345f0e44 (diff)
downloadaports-02847152f7ad083e86d665a94739e1d0c539034c.tar.bz2
aports-02847152f7ad083e86d665a94739e1d0c539034c.tar.xz
testing/sshuttle: new aport
Transparent proxy server using ssh https://github.com/sshuttle/sshuttle
Diffstat (limited to 'testing/sshuttle')
-rw-r--r--testing/sshuttle/APKBUILD32
-rw-r--r--testing/sshuttle/no-scm.patch18
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/sshuttle/APKBUILD b/testing/sshuttle/APKBUILD
new file mode 100644
index 0000000000..8651e17dce
--- /dev/null
+++ b/testing/sshuttle/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="sshuttle"
+pkgver="0.78.5"
+pkgrel=0
+pkgdesc="Transparent proxy server using ssh"
+url="https://github.com/sshuttle/sshuttle"
+arch="noarch"
+license="GPL-2.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov py3-mock py3-flake8"
+options="!check" # TODO: fix testsuite
+source="https://github.com/sshuttle/sshuttle/archive/v$pkgver/sshuttle-$pkgver.tar.gz
+ no-scm.patch
+ "
+builddir="$srcdir/sshuttle-$pkgver"
+
+build() {
+ echo "version = '$pkgver'" > sshuttle/version.py
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bf76bfbd1025ce8c7b72e946541b9cc8b678ba21049fef65df4929cb7a36684f259fc653b644da0c3c278fd26a38e218202d5debce243659a840b7f36acd5e20 sshuttle-0.78.5.tar.gz
+bdfcb1e88b4f2ce3906ed511697083ab789d5a8c1034bce25448cdd3195fb5e26ab403e7f3fdb97d4293cad4875dc08ed5071dafab145c70f654ab9ac40fb160 no-scm.patch"
diff --git a/testing/sshuttle/no-scm.patch b/testing/sshuttle/no-scm.patch
new file mode 100644
index 0000000000..33a317e40d
--- /dev/null
+++ b/testing/sshuttle/no-scm.patch
@@ -0,0 +1,18 @@
+diff --git a/setup.py b/setup.py
+index d5f3c7e..b90473d 100755
+--- a/setup.py
++++ b/setup.py
+@@ -28,12 +28,7 @@ def version_scheme(version):
+
+ setup(
+ name="sshuttle",
+- use_scm_version={
+- 'write_to': "sshuttle/version.py",
+- 'version_scheme': version_scheme,
+- },
+- setup_requires=['setuptools_scm'],
+- # version=version,
++ #version="",
+ url='https://github.com/sshuttle/sshuttle',
+ author='Brian May',
+ author_email='brian@linuxpenguins.xyz',