aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sslh
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-07 01:40:43 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-07 02:11:19 +0100
commit130e06710972dd17bcd77a948fbb3909d1ca2e79 (patch)
tree0acd1f6cbb0c75d1d87d1821b93cd351168d284b /testing/sslh
parent113057b4d1b1551170a6508950fd32eecc6c8143 (diff)
downloadaports-130e06710972dd17bcd77a948fbb3909d1ca2e79.tar.bz2
aports-130e06710972dd17bcd77a948fbb3909d1ca2e79.tar.xz
testing/sslh: replace outdated local config with upstream's
...but remove some irrelevant options.
Diffstat (limited to 'testing/sslh')
-rw-r--r--testing/sslh/APKBUILD6
-rw-r--r--testing/sslh/config.patch34
-rw-r--r--testing/sslh/sslh.conf25
3 files changed, 37 insertions, 28 deletions
diff --git a/testing/sslh/APKBUILD b/testing/sslh/APKBUILD
index 16a991fc2d..6320867ce8 100644
--- a/testing/sslh/APKBUILD
+++ b/testing/sslh/APKBUILD
@@ -14,7 +14,7 @@ source="http://www.rutschle.net/tech/$pkgname/$pkgname-v$pkgver.tar.gz
generate-version.patch
fix-make-install.patch
fail2ban.patch
- $pkgname.conf
+ config.patch
$pkgname.initd
$pkgname.confd
"
@@ -38,9 +38,9 @@ check() {
package() {
make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -D -m644 basic.cfg "$pkgdir/etc/$pkgname/$pkgname.conf"
install -D -m755 "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
install -D -m644 "$srcdir/$pkgname.confd" "$pkgdir/etc/conf.d/$pkgname"
- install -D -m644 "$srcdir/$pkgname.conf" "$pkgdir/etc/$pkgname/$pkgname.conf"
}
fail2ban() {
@@ -67,6 +67,6 @@ sha512sums="eccaddd5a4299206f195c2f7a78840b2f76f8a0cf10a715b5c72f959ed5d3259fc5e
66aa10eb497a8c44e7b852476b8fb9af05d6d786da76557f4b77799f871884531ac98f71313d7d449396fb02205b5a6248e957cecee7efaf7d17d69850dc88cf generate-version.patch
b82d3c799f0cdf183fe0545e1d2b4f142070112d7ec3594afd709608c4893c300122aa32026dd7f8e782eb3981bf85fc02f878e2613ddfe014f39bbb94fb441e fix-make-install.patch
5773ee1d91e099726b614dbe385f2668699d25029fc300b664411c6082e95d3f27df11b9b1489bee3444c81bf941b8db13b4d382343788e47408c593c4531816 fail2ban.patch
-dd2231677d3e3f371ef643ebb9b9e31effc058ac7b430fe17dfb801b23040c6bde7b6c7c6b0ff6757607207a506096334b0a8e7ce83c884d483717c338a3499c sslh.conf
+c5e3d6714c5588731c749feaed24a8d551d1fbdc527348209465b9416efe4713ff9715eb10867fea13fd5cbdf2ab41d52019fb93d4e5ead29e8fda47581598aa config.patch
ba0a0fe8785ab9963d4dc11c39d6cbd41fe14d1e8f6d61eb0bf6eb2855e4f2de119b76f82894f3d52a91467ee83f4bd805d8eafc3c7da7b5a4f630cc4a241462 sslh.initd
580114cef9356d66ec1e6c306837d44dc3098e8f3f805eda20c5d8f81f087bf295b25801ee64ee2bc667ce7324f510ff6f4fc7e222d1431ec3d4e82bbcfb160f sslh.confd"
diff --git a/testing/sslh/config.patch b/testing/sslh/config.patch
new file mode 100644
index 0000000000..02d5cb9c18
--- /dev/null
+++ b/testing/sslh/config.patch
@@ -0,0 +1,34 @@
+--- a/basic.cfg
++++ b/basic.cfg
+@@ -2,20 +2,17 @@
+ # sensible values for "standard" setup.
+
+ verbose: false;
+-foreground: false;
+-inetd: false;
+ numeric: false;
+ transparent: false;
+ timeout: 2;
+ user: "nobody";
+-pidfile: "/var/run/sslh.pid";
+ chroot: "/var/empty";
+
+
+-# Change hostname with your external address name.
++# Change host with your external address name.
+ listen:
+ (
+- { host: "thelonious"; port: "443"; }
++ { host: "0.0.0.0"; port: "443"; }
+ );
+
+ protocols:
+@@ -24,7 +21,6 @@
+ { name: "openvpn"; host: "localhost"; port: "1194"; },
+ { name: "xmpp"; host: "localhost"; port: "5222"; },
+ { name: "http"; host: "localhost"; port: "80"; },
+- { name: "ssl"; host: "localhost"; port: "443"; log_level: 0; },
++ { name: "tls"; host: "localhost"; port: "443"; log_level: 0; },
+ { name: "anyprot"; host: "localhost"; port: "443"; }
+ );
+-
diff --git a/testing/sslh/sslh.conf b/testing/sslh/sslh.conf
deleted file mode 100644
index 8bc52e84eb..0000000000
--- a/testing/sslh/sslh.conf
+++ /dev/null
@@ -1,25 +0,0 @@
-verbose: false;
-foreground: true;
-inetd: false;
-numeric: false;
-transparent: false;
-timeout: 2;
-user: "nobody";
-pidfile: "/var/run/sslh.pid";
-
-
-listen:
-(
- { host: "::0"; port: "443"; }
-);
-
-protocols:
-(
- { name: "ssh"; service: "ssh"; host: "localhost"; port: "22"; probe: "builtin"; },
- { name: "openvpn"; host: "localhost"; port: "1194"; probe: "builtin"; },
- { name: "xmpp"; host: "localhost"; port: "5222"; probe: "builtin"; },
- { name: "http"; host: "localhost"; port: "80"; probe: "builtin"; },
- { name: "ssl"; host: "localhost"; port: "8443"; probe: "builtin"; },
- { name: "anyprot"; host: "localhost"; port: "8443"; probe: "builtin"; }
-);
-