aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sslscan
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2018-12-13 22:18:27 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 09:54:13 +0000
commit99230fd1e4c0b0c43885de23a5377b10aab0ca22 (patch)
tree2e08999afdf651319c301b183f543911a806eb1f /testing/sslscan
parentdc9383d2b060b9630a624bc30d1fd5c0e3837869 (diff)
downloadaports-99230fd1e4c0b0c43885de23a5377b10aab0ca22.tar.bz2
aports-99230fd1e4c0b0c43885de23a5377b10aab0ca22.tar.xz
testing/sslscan: new aport
Fast SSL configuration scanner.
Diffstat (limited to 'testing/sslscan')
-rw-r--r--testing/sslscan/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/sslscan/APKBUILD b/testing/sslscan/APKBUILD
new file mode 100644
index 0000000000..6c99db0ce3
--- /dev/null
+++ b/testing/sslscan/APKBUILD
@@ -0,0 +1,37 @@
+pkgname=sslscan
+pkgver=1.11.12
+_openssl_commit="c9ba19c8b7fd131137373dbd1fccd6a8bb0628be"
+pkgrel=0
+pkgdesc="Fast SSL configuration scanner"
+url="https://github.com/rbsec/sslscan"
+arch="all"
+license="GPL-3.0-or-later OpenSSL"
+makedepends="zlib-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rbsec/sslscan/archive/$pkgver-rbsec.tar.gz
+ sslscan-openssl-$_openssl_commit.tar.gz::https://github.com/PeterMosmans/openssl/archive/$_openssl_commit.tar.gz"
+options="!check" # No test suite
+builddir="$srcdir/sslscan-$pkgver-rbsec"
+
+build() {
+ cd "$builddir"
+ ln -s "../openssl-$_openssl_commit" openssl
+ touch .openssl_is_fresh
+
+ sed -i -e '/openssl\/.git/,/fi/d' -e '/openssl test/d' Makefile
+
+ # Don't attempt to use strnstr
+ CFLAGS="$CFLAGS -D__USE_GNU"
+
+ # To compile against the openssl lib with insecure protocols enabled
+ make static
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+
+sha512sums="e667cc50f0ec71343b73ca11871a1a53aa9f255c671f16b7c5f33093125a1e60d6e7945e7bd7296f4a71aa6837c823dc939e18982f3e3f831acc061ead9e7ebb sslscan-1.11.12.tar.gz
+9bfdac0b6dcbb9e932ef41db9753f7298cf38ddc18731386968289114fd5ed10d81e95523d557b42b431377638d2f62fb710189e7d944ba89979fe5e3437fd3f sslscan-openssl-c9ba19c8b7fd131137373dbd1fccd6a8bb0628be.tar.gz"