aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sssd/0003-alpine.patch
diff options
context:
space:
mode:
authorVince Mele <vmele@inoc.com>2017-12-01 19:33:51 -0600
committerHenrik Riomar <henrik.riomar@gmail.com>2018-07-22 23:48:52 +0200
commit0d728f6131640b7198af4cb998eacb519d86c076 (patch)
tree4297b64835ba0a27d994dacb62fd6759eb336b11 /testing/sssd/0003-alpine.patch
parent205bd021b3c9457a989443d458379467b63218ef (diff)
downloadaports-0d728f6131640b7198af4cb998eacb519d86c076.tar.bz2
aports-0d728f6131640b7198af4cb998eacb519d86c076.tar.xz
testing/sssd: new aport
Diffstat (limited to 'testing/sssd/0003-alpine.patch')
-rw-r--r--testing/sssd/0003-alpine.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/testing/sssd/0003-alpine.patch b/testing/sssd/0003-alpine.patch
new file mode 100644
index 0000000000..043975d579
--- /dev/null
+++ b/testing/sssd/0003-alpine.patch
@@ -0,0 +1,105 @@
+--- sssd-1.15.3/src/external/platform.m4
++++ sssd-1.15.3-old/src/external/platform.m4
+@@ -1,5 +1,5 @@
+ AC_ARG_WITH([os],
+- [AC_HELP_STRING([--with-os=OS_TYPE], [Type of your operation system (fedora|redhat|suse|gentoo)])]
++ [AC_HELP_STRING([--with-os=OS_TYPE], [Type of your operation system (fedora|redhat|suse|gentoo|alpine)])]
+ )
+ osname=""
+ if test x"$with_os" != x ; then
+@@ -7,6 +7,7 @@
+ test x"$with_os" = xredhat || \
+ test x"$with_os" = xsuse || \
+ test x"$with_os" = xgentoo || \
++ test x"$with_os" = xalpine || \
+ test x"$with_os" = xdebian ; then
+ osname=$with_os
+ else
+@@ -25,6 +26,8 @@
+ osname="debian"
+ elif test -f /etc/gentoo-release ; then
+ osname="gentoo"
++ elif test -f /etc/alpine-release ; then
++ osname="alpine"
+ fi
+
+ AC_MSG_NOTICE([Detected operating system type: $osname])
+@@ -35,6 +38,7 @@
+ AM_CONDITIONAL([HAVE_SUSE], [test x"$osname" = xsuse])
+ AM_CONDITIONAL([HAVE_DEBIAN], [test x"$osname" = xdebian])
+ AM_CONDITIONAL([HAVE_GENTOO], [test x"$osname" = xgentoo])
++AM_CONDITIONAL([HAVE_ALPINE], [test x"$osname" = xalpine])
+
+ AC_CHECK_MEMBERS([struct ucred.pid, struct ucred.uid, struct ucred.gid], , ,
+ [[#include <sys/socket.h>]])
+--- sssd-1.15.3/Makefile.am
++++ sssd-1.15.3-old/Makefile.am
+@@ -4423,12 +4419,16 @@
+ init_SCRIPTS += \
+ src/sysv/gentoo/sssd
+ else
++if HAVE_ALPINE
+ init_SCRIPTS += \
++ src/sysv/alpine/sssd
++else
++ init_SCRIPTS += \
+ src/sysv/sssd
+ endif
+ endif
+ endif
+-
++endif
+
+ dist_sssddata_DATA = \
+ src/config/etc/sssd.api.conf \
+--- sssd-1.15.3-old/configure.ac
++++ sssd-1.15.3/configure.ac
+@@ -491,7 +491,7 @@
+
+ AC_CONFIG_FILES([Makefile contrib/sssd.spec src/examples/rwtab src/doxy.config
+ contrib/sssd-pcsc.rules
+- src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd
++ src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd src/sysv/alpine/sssd
+ po/Makefile.in src/man/Makefile src/tests/cwrap/Makefile
+ src/tests/intg/Makefile
+ src/lib/ipa_hbac/ipa_hbac.pc src/lib/ipa_hbac/ipa_hbac.doxy
+--- /dev/null
++++ sssd-1.15.3/src/sysv/alpine/sssd
+@@ -0,0 +1,17 @@
++#!/sbin/openrc-run
++
++depend(){
++ need localmount netmount clock
++}
++
++start(){
++ ebegin "Starting sssd"
++ start-stop-daemon --start --exec ${exec_prefix}/usr/sbin/sssd -- -Df ${SSSD_OPTIONS}
++ eend ${?}
++}
++
++stop(){
++ ebegin "Stopping sssd"
++ start-stop-daemon --stop --pidfile ${prefix}/var/run/sssd.pid
++ eend ${?}
++}
+--- /dev/null
++++ sssd-1.15.3/src/sysv/alpine/sssd.in
+@@ -0,0 +1,17 @@
++#!/sbin/openrc-run
++
++depend(){
++ need localmount netmount clock
++}
++
++start(){
++ ebegin "Starting sssd"
++ start-stop-daemon --start --exec ${exec_prefix}/usr/sbin/sssd -- -Df ${SSSD_OPTIONS}
++ eend ${?}
++}
++
++stop(){
++ ebegin "Stopping sssd"
++ start-stop-daemon --stop --pidfile ${prefix}/var/run/sssd.pid
++ eend ${?}
++}